Diablo 2 mods
 


Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sat Nov 25, 2017 1:48 am 
 Post subject: Custom monster animation cannot land hits
 
Offline
Warrior

Joined: Mon Mar 30, 2015 7:30 pm
Posts: 15
Gender: None specified
I've managed to implement a few of the monster animations from Infinitum, but I've run across a couple animations that work but can't seem to hit the player.

Even though the animations work, and they have A1, A2, and S1s - none of them seem to be able to make actual contact. I've tried different AIs, tried all the attack animations it has but notta.

An example of this is the Amelyssan on the Infinitum - works great but can't hit {filtered}.

Anyone know what this is about and what corrective measures need to be taken?


Top
 Profile  
Reply with quote  
PostPosted: Sat Nov 25, 2017 4:42 am 
 Post subject: Re: Custom monster animation cannot land hits
 
Offline
Angel
User avatar

Age: 25
Joined: Wed May 25, 2011 11:50 pm
Posts: 827
Gender: Male
Animdata > framedata iirc

_________________
PureRage wrote:
Durrrp, durrrp. idiot


Top
 Profile  
Reply with quote  
PostPosted: Sat Nov 25, 2017 5:33 am 
 Post subject: Re: Custom monster animation cannot land hits
 
Offline
Warrior

Joined: Mon Mar 30, 2015 7:30 pm
Posts: 15
Gender: None specified
Doh! That was definitely it, thank you!

Seems I can't entirely rely on the anim data lines provided all the time :o


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Black Rock template by onyx (based on BlackSoul for phpBB2)