Error

Information and updates for mods and plugins created by Talonrage. If you have any questions or suggestions, please post them here. Click here to visit the official web site.

Moderator: talonrage

Post Reply
Tableau123
Posts: 3
Joined: Tue Apr 21, 2020 1:58 am
Canada

Error

Post by Tableau123 » Tue Apr 21, 2020 5:00 am

Hello y'all, hope everyone is keeping safe at home ...

Decided to give all this a try with that new time on my hands! (you got it i'm a noob at this).

So I managed to download Cactus program which is a bit like D2SE but I think better (or not?), anyway I can't get d2SE to work on my cpu it seems.

Running Win10 and trying to play Requiem of Sorrow with Cactus; I merged the files with the 1.10 version like it is suggested (made a copy of 1.10 folder than parsed the RoS' files into that folder). I couldn't really see anywhere how you are supposed to make a mod work with Cactus but I assume this must be the way...

Now, I can launch the game, create a character but when it's about to enter the game (single player) I get this :

halt
location : d2client\engine\gfx.cpp, line #1243 expression : gfx.cpp
Mode (0) is not used by object (0)

I tried the other patches, even 'Succulent' mod by Cactus' own creator and everything seems to work. But not when I try with Requiem of Sorrow!
Oh yeah I believe it's version 6.08 I am using for the RoS version.

Any hint on this? Would be greatly appreciated...
Thanks!!


PS: if y'all got any other mod to suggest that might be easier to make work (cause I read RoS is difficult to make work on machines higher than Win7 I am definitively all ears (srsly tried for around 3h to make this one work with no success))... I tried Median XL but just think it's too much, it's completely a different game from d2 at that point. A mod with a few new RW/uniques/sets/Cube recipes, some new/reworked skills, a few new baddies/quests/maps and of course some 'life easiness' aspects like the sharables or bigger stashes is the kind of stuff I'm looking for... something similar to RoS in other words!

User avatar
Cypress
Posts: 97
Joined: Fri Dec 01, 2017 2:08 am

Re: Error

Post by Cypress » Tue Apr 21, 2020 2:38 pm

Requiem of Sorrow works fine for me and I'm on Windows 10.

I managed to replicate your error by removing BOL.dll, so I presume your error is from failing to load this file. Does "D2mod System 1.02" show up at the bottom left of the main menu? If it isn't there, then that means a bunch of vital files aren't going to be loading which will break the mod.

Does "PlugY" show up at the bottom right of your screen? If it does, and the D2mod System doesn't, then you can force the game to load the D2mod System via PlugY by opening PlugY.ini and putting D2mod.dll after DllToLoad= (so it would probably look like "DllToLoad=D2mod.dll").

As for other mods that I'd suggest that are somewhat similar to Diablo 2: Walhalla, Eastern Sun, Reign of Shadows, Battle for Elements, Nezeramontias and D2scrabble (with Walhalla being the most similar to vanilla and each following mod being increasingly less similar).

Tableau123
Posts: 3
Joined: Tue Apr 21, 2020 1:58 am
Canada

Re: Error

Post by Tableau123 » Tue Apr 21, 2020 6:26 pm

Cypress wrote:
Tue Apr 21, 2020 2:38 pm
Requiem of Sorrow works fine for me and I'm on Windows 10.

I managed to replicate your error by removing BOL.dll, so I presume your error is from failing to load this file. Does "D2mod System 1.02" show up at the bottom left of the main menu? If it isn't there, then that means a bunch of vital files aren't going to be loading which will break the mod.

Does "PlugY" show up at the bottom right of your screen? If it does, and the D2mod System doesn't, then you can force the game to load the D2mod System via PlugY by opening PlugY.ini and putting D2mod.dll after DllToLoad= (so it would probably look like "DllToLoad=D2mod.dll").

As for other mods that I'd suggest that are somewhat similar to Diablo 2: Walhalla, Eastern Sun, Reign of Shadows, Battle for Elements, Nezeramontias and D2scrabble (with Walhalla being the most similar to vanilla and each following mod being increasingly less similar).
Hey man I do appreciate your help on this.

All I can see on the may menu on the bottom left is '1.10' and that's it ; no plugy on the bottom right. D2mod System 1.02, I can't see that anywhere on the main menu. There really just is the 1.10, but the starting screen is definitively the one from RoS.
Any clue as why it wouldn't load those other files ?? FYI BOL.dll is here and well in the folder ... not too sure what I should do now !
Also thanks a bunch for the recommendations ;)
EDIT: tryring to add the actual and other starting screen screenshot but seems it's too heavy ... oh well

User avatar
Cypress
Posts: 97
Joined: Fri Dec 01, 2017 2:08 am

Re: Error

Post by Cypress » Wed Apr 22, 2020 1:41 pm

I have it working now for Cactus.

You need to download PlugY (I'd recommend 11.02 since it is the newest and works) and put that into your Requiem of Sorrow platform. Go into the new PlugY.ini and add in D2Mod.dll after DlltoLoad=. Then set up Cactus to run off PlugY.exe instead of Game.exe for Requiem of Sorrow. If it successfully runs PlugY.exe, then it should also boot up the D2mod System.

Also, thanks for talking about Cactus, I didn't even know it existed but it has quite a few features that make it a great supplement to D2SE since it supports all versions.

Tableau123
Posts: 3
Joined: Tue Apr 21, 2020 1:58 am
Canada

Re: Error

Post by Tableau123 » Mon May 04, 2020 4:48 am

Cypress wrote:
Wed Apr 22, 2020 1:41 pm
I have it working now for Cactus.

You need to download PlugY (I'd recommend 11.02 since it is the newest and works) and put that into your Requiem of Sorrow platform. Go into the new PlugY.ini and add in D2Mod.dll after DlltoLoad=. Then set up Cactus to run off PlugY.exe instead of Game.exe for Requiem of Sorrow. If it successfully runs PlugY.exe, then it should also boot up the D2mod System.

Also, thanks for talking about Cactus, I didn't even know it existed but it has quite a few features that make it a great supplement to D2SE since it supports all versions.
Really glad I could make someone learn something new then :cool:

On my end, I tried the exact steps you've recommended. I tried them once, then took some break time and tried again with a more calm mind. I just can't seem to make this works, this is getting on my nerves lol. I am having the exact same error. Feels like there is a-l-w-a-y-s something wrong. At some point it wouldn't even let me change the path to 'Game.exe' saying it was wrong ... I really just don't know what's going here.

If you have a last resort trick up your sleeve... I'm all ears!

User avatar
Cypress
Posts: 97
Joined: Fri Dec 01, 2017 2:08 am

Re: Error

Post by Cypress » Mon May 04, 2020 4:49 pm

These are the exact steps I used to run it on Cactus version 1.2.2:

1) Download: https://www.moddb.com/games/diablo-2-lo ... w-v608-sfx
2) Download: http://plugy.free.fr/PlugY_The_Survival_Kit_v11.02.zip
3) Extract Requiem of Sorrow into the Platforms folder
4) Extract PlugY into the Requiem of Sorrow folder (replace any duplicates)
5) In PlugY.ini, set DllToLoad=D2Mod.dll
6) Copy the contents of Platform 1.10 into the RequiemofSorrow folder (do NOT replace anything)
7) From Cactus: Platform=RequiemofSorrow, path=D:\D\Cactus Diablo II\PlugY.exe, flags=-win -3dfx

Your path should be set up exactly the same as your other platforms, just instead of Game.exe put in PlugY.exe. For the flags, I am for some reason getting crashes unless I set it to window mode (-win) so I'd recommend that. Glide is optional, although I think it looks a lot better. Some mods don't work with certain graphics modes, so I recommend testing each of them independently and seeing which works best (default is DDraw, Glide=-3dfx, Direct3D=-d3d).

If Cactus is screwing up, be sure to run a different platform first, then afterwards run your desired platform, or untick the "last ran" box (if you don't do this, it'll think nothing has changed, and thus won't move anything new that you place in the given platform).

This is the process that should work for any mod:

1) Place the contents of the mod into its own platform
2) Find what version the mod is meant to run off of, then copy the respective platform into it (so if it is a 1.13c mod, copy the contents of 1.13c into the mod folder) and DO NOT replace anything
3) If the mod comes with its own exe/launcher (it could be a custom Game.exe, PlugY.exe or something else), set the path to that exe/launcher and you should be able to run the mod
4) If the mod does not come with its own exe/launcher, then extract PlugY 11.02 into the folder and replace, then set the path to run off PlugY.exe; if the mod already has its own PlugY.ini, then I strongly recommend comparing the two PlugY.inis and changing the PlugY.ini 11.02 to match the settings of the mod's replaced PlugY.ini (this makes sure that you have the same settings for PlugY as the modder intended; this won't necessarily make a big difference and in most cases it doesn't matter, but it can since some mods do things like enable ladder runewords or give more skill points/stats per level via the PlugY.ini)
-
5) If the mod has D2mod.dll (this mod will always be 1.10f) or Nefex.dll (this mod will always be 1.11b), then set Dlltoload=D2mod.dll or Dlltoload=Nefex.dll in the PlugY.ini
6) If the mod includes a "Data" folder, then be sure to set "-dir -txt" into the Flags; this will make it so the game knows to read from the "Data" folder (if you want to be safe, I think you can set every mod to run off of "-dir -txt" and it shouldn't cause any issues, even if the mod doesn't have a "Data" folder)

Post Reply

Return to “Talonrage's Requiem of Sorrow”