Cannot start the mod (1.14) 5.0.3

Information and updates for the "Le Royaume des Ombres" mod by Xaphan. If you have any questions or suggestions for these mods, please post them here.

Moderator: Xaphan

Post Reply
WiZoRZ
Posts: 3
Joined: Sat Jun 11, 2016 2:16 am

Cannot start the mod (1.14) 5.0.3

Post by WiZoRZ » Sat Jun 11, 2016 2:20 am

The mod won't open at all. Nothing happens.

5.0.3 version.

Tried every video settings, windowed mode... And when I press d2vidtest an error happens. Could not locate d2se_setup.ini

On diablo 1.14 too. I've read that the mod was supporting ''any'' versions, am I correct?

Just freshly reinstalled diablo and everything. (note that I MUST install a glide wrapper to open diablo without the infamous ACCESS VIOLATION.


New to this mod and forum, sorry if it's been answered or anything, I have difficulty to navigate and find stuff overhere

User avatar
bleedingapathy
Dark Alliance Beta Test
Paladin
Posts: 172
Joined: Fri Jan 03, 2014 1:20 am
Location: the black abyss

Re: Cannot start the mod (1.14) 5.0.3

Post by bleedingapathy » Sat Jun 11, 2016 7:43 am

your better off downgrading your diablo to 1.10 up to 1.13c 1.14 casues more problems than it's worth imo. and do you have d2se installed on your pc?

Grinch
Posts: 11
Joined: Sat Apr 02, 2016 12:00 pm

Re: Cannot start the mod (1.14) 5.0.3

Post by Grinch » Sat Jun 11, 2016 7:56 am

If i remember it's a 1.10 Mod so u have to use 1.10.
Downloading 1.14 and downgrade doesn't work so u have to install it from CD's and upgrade it to the version or download an older battle.net client with version 1.13d or lower.

Also d2se is the best choice you can go with, but u can't install it on 1.14x either.

WiZoRZ
Posts: 3
Joined: Sat Jun 11, 2016 2:16 am

Re: Cannot start the mod (1.14) 5.0.3

Post by WiZoRZ » Sat Jun 11, 2016 5:51 pm

Tried reinstalling diablo using the cd, manually updated to 1.10. Still the problem. I open the mod VIA d2se and then nothing happens.

UPDATE : Finally managed to get it open by putting D2SE in windows 7 compability mode.

Grinch
Posts: 11
Joined: Sat Apr 02, 2016 12:00 pm

Re: Cannot start the mod (1.14) 5.0.3

Post by Grinch » Sat Jun 11, 2016 6:06 pm

If u using D2SE install 1.13C - D2SE will downgrade the game to 1.10 if needed (but u also can play other mods which use an other version then 1.10.

User avatar
Xaphan
Hosted Forum Moderator
Arch-Angel
Posts: 1110
Joined: Fri Oct 08, 2010 10:55 am
France

Re: Cannot start the mod (1.14) 5.0.3

Post by Xaphan » Sat Jun 11, 2016 9:53 pm

The mod run on 1.10 but with D2SE it work on any version because D2SE do the job, but I duno if D2SE is compatible with 1.14.

But it look like you solved your issue so all good :)

s520864
Posts: 1
Joined: Sat Jul 23, 2016 3:17 am

Re: Cannot start the mod (1.14) 5.0.3

Post by s520864 » Sat Jul 23, 2016 3:19 am

im having the same issue, can someone walk me through the steps on how to fix the issue?

qndel
Posts: 9
Joined: Wed Nov 16, 2016 3:45 pm

Re: Cannot start the mod (1.14) 5.0.3

Post by qndel » Wed Nov 16, 2016 5:52 pm

Set d2se to windows 7 compatibility mode - helped me too :)

User avatar
Xaphan
Hosted Forum Moderator
Arch-Angel
Posts: 1110
Joined: Fri Oct 08, 2010 10:55 am
France

Re: Cannot start the mod (1.14) 5.0.3

Post by Xaphan » Wed Nov 16, 2016 6:54 pm

Tests revealed that D2SE is not compatible with version 1.14, so that mean the mod is not as well. Only way to fix it, for now, is to have an istall that is every other version but 1.14.

User avatar
ChaosMarc
Dark Alliance Beta Test
Paladin
Posts: 216
Joined: Fri May 28, 2004 2:00 pm
Germany

Re: Cannot start the mod (1.14) 5.0.3

Post by ChaosMarc » Wed Nov 16, 2016 10:13 pm

@Xaphan: This is not entirely true. D2SE works perfectly on a 1.14 installation IF diablo was NOT installed with the new 1.14 digitial download installers. If you install the game with your cds or the old 1.12 digital download installers and patch diablo to 1.14 (either via battle.net or manual) D2Se works fine (with the correct compatibility options of course: WinXP SP3 + deactivate scaling on high dpi).
I haven't tested LRoO though as I have never played it ;)

PS: you can download the old installers here: https://mega.nz/#F!VIth1DKQ!Q42bVsCGQZ4UhoGjqvHxGw

User avatar
SpiKe.
Dark Alliance Beta Test
Champion of the Light
Posts: 280
Joined: Thu Jul 28, 2011 5:25 pm
Location: Germany
Contact:
Germany

Re: Cannot start the mod (1.14) 5.0.3

Post by SpiKe. » Wed Nov 16, 2016 11:18 pm

D2SE doesn't support 1.14. So using 1.14 can and will end in random crashes sometimes. If mods use Plugins like D2Mod (for 1.10) they can't get read at some point and the game will crash.
To have a clean install, D2SE needs to be installed over 1.13c. Seltsamuel is working on 1.14x at the moment, so hopefully there will be a release for 1.14x in near future.
Image

User avatar
ChaosMarc
Dark Alliance Beta Test
Paladin
Posts: 216
Joined: Fri May 28, 2004 2:00 pm
Germany

Re: Cannot start the mod (1.14) 5.0.3

Post by ChaosMarc » Thu Nov 17, 2016 8:02 am

It is absolutely irrelevant on which version of diablo D2SE was installed (with the exception of the new installers as I mentioned earlier).
When you create a D2SE plugin for a mod you choose with which base patch the mod should be started. When launching the plugin D2SE starts exactly this base patch version with the mod files on top of it. For LRoO it should be 1.10f as D2ModSystem is used if I understood it correctly.
The update Seltsamuel is working on will bring support for mods BASED on 1.14 not the ability to start mods based on other patches on a 1.14 installation.

The only thing that forces you to install D2SE on a specific diablo version is a topic we're not allowed to talk about here. If this is the case you should patch diablo (doesn't matter if you do it before or after installing D2SE) to the patch the mod is based on as the system we're not allowed to talk about will probably run the same patch version and check for it. This is a bug the D2SE update will fix too so that the base patch of the mod will be checked for compatibility and not the version of your diablo installation

venix
Posts: 2
Joined: Sat Feb 24, 2018 11:46 am
Vietnam

Re: Cannot start the mod (1.14) 5.0.3

Post by venix » Sat Feb 24, 2018 11:55 am

i cant start the game too, d2 13.3c with the mod public beta, also tried reinstall, change display, every video settings or others window compability mode neither. Please help me.

User avatar
AlphA - The Real One
Hosted Forum Moderator
Champion of the Light
Posts: 291
Joined: Sat Oct 31, 2009 12:28 pm
Location: China
Germany

Hand-picked

Re: Cannot start the mod (1.14) 5.0.3

Post by AlphA - The Real One » Sat Feb 24, 2018 3:08 pm

Installed D2SE? Does D2SE work? Do other mods work? If its a D2SE problem you might wanna ask in the Snej Fourm for help.

Cheers
AlphA

venix
Posts: 2
Joined: Sat Feb 24, 2018 11:46 am
Vietnam

Re: Cannot start the mod (1.14) 5.0.3

Post by venix » Mon Mar 05, 2018 11:48 pm

Oh well, i've found down that changing the window compability of D2SE into window 7, it will work normally. Thanks anyway.

User avatar
Xaphan
Hosted Forum Moderator
Arch-Angel
Posts: 1110
Joined: Fri Oct 08, 2010 10:55 am
France

Re: Cannot start the mod (1.14) 5.0.3

Post by Xaphan » Wed Mar 07, 2018 1:52 am

Glad it goes sorted out :)

Post Reply

Return to “Le Royaume des Ombres”