[Solved] CtC Curses On Armor Not Working

Post here about all aspects of D2 mod making whether it's information, problems or whatever. Please specify whether your post is relating to Classic D2 or the Expansion.

Moderator: Nizari

Post Reply
User avatar
ModOfD2
Posts: 1
Joined: Fri Jun 22, 2018 8:05 pm
Germany

[Solved] CtC Curses On Armor Not Working

Post by ModOfD2 » Sun Sep 02, 2018 3:30 am

I've got a question concerning CtC curses. I use att-skill, hit-skill, gethit-skill, etc... to add chance to cast curse x property on attack/striking/... to unique items. Everything works as it should, at least as for weapons. Unfortunately if I try to use it on armor (shields, body armor, etc...), the curses' area effect animations + sounds trigger, but no enemy in range seems to get affected by it (no "cursed"-sound or overhead-animation). The only exception is Life Tap, which works properly. Amplify Damage or Lower Resist for example are problematic cases.

Can anyone explain me what causes the problem and is there a way to solve it?
Game Version is Diablo 2 Expansion 1.14d

Edit: I came across this thread viewtopic.php?t=65270 and noticed that my necro's curses didn't work either. After reextracting skills.txt and using AFJ Sheet instead of Excel, my problem was solved. Now enemies in range get affected by curses triggered by item events on armor.

Whatever I'm still curious why it worked only on weapons respectively only with Life Tap on armor before.

Post Reply

Return to “General Mod Making”