Problem with Goblins

Post here about all aspects of D2 mod making whether it's information, problems or whatever. Please specify whether your post is relating to Classic D2 or the Expansion.

Moderator: Nizari

Post Reply
User avatar
Specktro
Posts: 23
Joined: Sat Jun 10, 2017 12:49 am
Location: Rio Grande do Sul, Brasil
Brazil

Problem with Goblins

Post by Specktro » Mon Nov 26, 2018 6:41 pm

I'm using the d3 goblins plugin, and it was working nice when I set it on my mod, but after some more things I added on the mod, I was testing the goblin drop and I've got a bug, instead of dying the goblin runs away in the portal... and it never runs away while I'm attacking it, no matter the time I spent hitting it... and when the hp goes to zero, it runs to portal.. And the image was ok back then and now the portal animation has some pinky squared frames arround the portal... DId I do something wrong?
Image
She sells Sea Shells by the sea shore...

User avatar
Nizari
Senior Moderator
Knight
Posts: 49
Joined: Fri Feb 16, 2018 11:39 pm
Poland

Re: Problem with Goblins

Post by Nizari » Mon Nov 26, 2018 6:54 pm

Sounds like messed up AI, cof files, animdata and probably almost everything else.


User avatar
Specktro
Posts: 23
Joined: Sat Jun 10, 2017 12:49 am
Location: Rio Grande do Sul, Brasil
Brazil

Re: Problem with Goblins

Post by Specktro » Tue Nov 27, 2018 12:37 am

Ogodei wrote:
Mon Nov 26, 2018 7:00 pm
The information you provided aren't enough to let people help you. Try to be a bit more specific and tell us what you added and\or what you changed concerning the goblins :)
The plugin was working fine... Cof files, txt lines, animdata, everything was ok and working... I just added some more monsters, created some skills, missiles etc... And I'm sure I didn't modify nothing concerning to the goblins, I even remade everything again from scratch (goblin plugin), but the thing is... I finished my mod and was testing on all modes.. And few times I've found the different gobs and noticed that, when I hit the goblins, the hitting animation ( that usually drops a coin), is not working, and when I kill it, instead of the dying animation, the often activate the "run away" animation, entering on a portal (no drops resulting) or they just vanish (no drops resulting)...

I remade from scratch on a "new" mod, making it the first change in the game, and everything works fine, but when I put on my mod, I have those bugs... But the more important detail about all this is, in NORMAL mode, everything work fine...
On Night or Hell, I have the problems...


Edit:
I don't understand EXACTLY how the levels.txt works around monsters spawning...
In Mon1-10 columns if I put the goblin it spawns in normal and works fine... But doesn't spawn in Night or Hell (I've set sparsePopulate to 100 on monstats.txt to be sure of its spawn)... If I put the goblin on the Nmon1-10 or Umon 1-10 columns, the gobs spawn in Night and Hell mode, but with the graphic issues and the no drop/run instead of die bug...

Maybe it should clarify your expert minds to help me.... hahaha..

Thanks guys...
Image
She sells Sea Shells by the sea shore...

User avatar
Specktro
Posts: 23
Joined: Sat Jun 10, 2017 12:49 am
Location: Rio Grande do Sul, Brasil
Brazil

Re: Problem with Goblins

Post by Specktro » Tue Nov 27, 2018 2:28 am

SOLVED!!

Monprop.txt
State 184 for Nightmare and Hell...

TreasureclassEx.txt
Created TC for Nighmare and Hell

Realy noob solutions, but made me think a lot about what was making the gobs use the DT animation in NM and Hell instead of exploding like in Normal... "Uberminions explode!" I thought... Took a look in Monprop and there it was... As I was using the plugin as it was, and it only had the props for normal mode, and TC had the same problem, only set for normal mode...

Sorry for all the annoyance, it took me time but after all I should spend this time and then ask here after trying more... :roll:
Image
She sells Sea Shells by the sea shore...

Post Reply

Return to “General Mod Making”