new monsters sound issue

Post here about all aspects of D2 mod making whether it's information, problems or whatever. Please specify whether your post is relating to Classic D2 or the Expansion.

Moderator: Nizari

Post Reply
User avatar
jaeyun3576532
Posts: 14
Joined: Sat Nov 05, 2016 10:35 pm

new monsters sound issue

Post by jaeyun3576532 » Wed Jan 18, 2023 3:39 am

long story short, I have an issue with the new monsters' sound effects. It seems like the game does not recognize sound effects for the new monsters. Thus, I thought that I might need to edit dll files.... yes, I have looked up everywhere on the website just in case somebody had the same issue. I saw that someone else had a problem just adding new monsters. However, my issue is different from that. Everything else(animation data, cof file, skills) works so dawg on fine besides sound effects. I have literally been stuck with this same issue for the past several days.... I think I really need to get some help..... coz this is soo mind draining....

User avatar
Ogodei
Senior Moderator
Angel
Posts: 511
Joined: Thu Mar 10, 2016 8:31 am
Italy

Hand-picked

Re: new monsters sound issue

Post by Ogodei » Wed Jan 18, 2023 8:18 am

If I recall correctly, Monster sounds are in .wav format , either mono or stereo, set to 22050 hz and 16-bit.

Also remember that, in case, the correct path is Data\Global\sfx\monster\your folder (not "monsterS").

Did you try converting the sounds like that?

I hope this helps.

User avatar
jaeyun3576532
Posts: 14
Joined: Sat Nov 05, 2016 10:35 pm

Re: new monsters sound issue

Post by jaeyun3576532 » Thu Jan 19, 2023 8:30 pm

@ ogodei yes everything is in the right place and all sounds files are in wav format

Post Reply

Return to “General Mod Making”