The game fails to read recent changes to skillicon.dc6 after transferring a mod from another computer.

Post here about all aspects of D2 mod making whether it's information, problems or whatever. Please specify whether your post is relating to Classic D2 or the Expansion.

Moderator: Nizari

Post Reply
OrderOfTheScribble
Posts: 28
Joined: Wed Apr 05, 2023 7:35 pm
United States of America

The game fails to read recent changes to skillicon.dc6 after transferring a mod from another computer.

Post by OrderOfTheScribble » Thu May 25, 2023 6:57 pm

I've recently been updating one of my old practice (read: not intended for release) mods that I originally started on my previous computer. All my txt edits have worked so far, but when I tried to add new item only skills and give them icons, the game crashes when I open the skill selection after gaining those new skills. This means the new skills are missing icons, which means the edits I made to skillicon.dc6 aren't read by the game. Here's some additional info:
  • To confirm it was a failure to read the changes and not a bug of the new icons, I replaced an existing icon with one of the new icons and edited skilldesc.txt to make the new skill point to the location of the replaced icon. In-game, this made the new skill no longer crash, but it showed the old icon.
  • I used DC6 Creator for dc6 editing. Normally, this program works for dc6 editing, but when I saved the skillicon.dc6 in question, the game acted like I didn't edit the file.
  • In case it was a permission issue, I went to skillicon.dc6 and gave users full control, but the game still failed to read the changes. I've had to give users full control of ini files I copied before I could edit them, which is why I tried it here.
The end result is that there's a desync between the skillicon.dc6 read by the game (which doesn't have the changes) and the version of the file I see on DC6 Creator. Is there any way to resync the files? I don't mind redoing the changes as long as I can get the game to read them.

EDIT: I was able to solve this issue by opening DC6 Creator as an administrator. When I did that, I saw the version of the file the game was reading and was able to edit that. What I don't get is why the program would show a fake version of the file when not opened as an administrator instead of just reverting the changes when a permission error makes such changes unread.

Post Reply

Return to “General Mod Making”