V1.10 and V1.09 on same PC

Information and updates for the Zy-El mod. If you have any questions or suggestions for the mods, please post them here. Click here to visit the official web site.

Moderators: Kato, d2vern

Post Reply
Tanis788
Posts: 77
Joined: Sat May 14, 2005 12:53 am

V1.10 and V1.09 on same PC

Post by Tanis788 » Sat May 14, 2005 3:51 pm

Can someone direct me to a file that allows me to change me versions from 1.10 to 1.09 and back. I've had it before but i want to be able to play both versions and test this mod.
Last edited by Tanis788 on Sun May 15, 2005 6:37 pm, edited 1 time in total.

Damascus329
Posts: 22
Joined: Wed Oct 08, 2003 11:54 am

Re: V1.10 to V1.09

Post by Damascus329 » Sun May 15, 2005 4:44 pm

I can't tell you where to download this file but i can tell you how to creat one.

What you do id you uninstall diablo 2(back up your mod stuff) then reinstall it. then update to 1.09. then make a folder and put a copy of the dlls exe''s and patchd2.mpq and put it in that folder. Update to 1.10. make a similar folder. now whenever you want to switch you can simply dump the appropriate folder into your d2 folder.

User avatar
Myhrginoc
Retired Admin
Cherub
Posts: 12062
Joined: Sat May 25, 2002 7:28 am
Location: Percussion U

Hand-picked

Re: V1.10 to V1.09

Post by Myhrginoc » Sun May 15, 2005 6:20 pm

MickyBIs came up with an easier variant, but it still requires reinstalling D2. Install and patch up to v1.09 (b or d, but d has more support in general). Now copy the DLLs, game.exe and patch_D2.mpq into a backup directory as mentioned before.

Make a copy of game.exe in the Diablo II directory and rename the copy game109d.exe (or game109b.exe if you use that version). Now update to v1.10 so you can play on Battle.net or use any 1.10 mods.

In the Zy-El directory, copy all the 1.09 DLLs from your backup directory, but don't overwrite any of the DLLs that came with Zy-El. Edit your shortcut to point to game109d.exe (or game109b.exe) but leave everything else the same. If you use our mod running scripts, look for the line that says

D2CmdLine = chr(34) & D2Path & "game.exe" & chr(34) & "-direct"

and change it to

D2CmdLine = chr(34) & D2Path & "game109d.exe" & chr(34) & "-direct"

(Ignore the -direct switch, that has no effect on an mpq-only mod.)

This may seem like a lot of steps, but you do it only once. Thereafter, whenever you want to run Zy-El you get v1.09, but leave your main install untouched for running v1.10 anywhere else. (This also works with other v1.09 mods, btw.)

I have heard of at least one person keeping configurations all the way up from the original v1.00, but unless you have an old mod you really like on your machine, 1.09d is probably the only other version you would need.
Do the right thing. It will gratify some people and astonish the rest.
~ Mark Twain
Run Diablo II in any version for mods: tutorial
The Terms of Service!! Know them, abide by them, and enjoy the forums at peace.
The Beginner's Guide v1.4: (MS Word | PDF) || Mod Running Scripts || TFW: Awakening

User avatar
Kato
Retired staff
Virtue
Posts: 4335
Joined: Mon Jun 03, 2002 4:36 pm
Location: Somewhere out there beyond the pale blue moon

Re: V1.10 and V1.09 on same PC

Post by Kato » Sun May 15, 2005 6:38 pm

:cool: Very good! Since Zy-El is "retro" mod using an earlier patch version, I can see a lot of players wanting to keep both patch versions on their machines.

:idea: It'll come in handy when Myrada for 1.10 comes out!! :P
"Do not be too proud of this technological terror you've constructed." - D.Vader
Zy-El: Trial by Fire Mod Forum: http://phrozenkeep.it-point.com/forum/v ... m.php?f=53
Zy-El website: http://www3.telus.net/zyel/index.html Zy-El wiki: http://zyel.wikispaces.com/

User avatar
timmermac
Junior Member
Paladin
Posts: 155
Joined: Tue Aug 19, 2003 9:55 pm

Re: V1.10 and V1.09 on same PC

Post by timmermac » Sun May 15, 2005 6:58 pm

I've got an even better way to handle mods with different patch versions. This one needs a fair amount of hard drive space, but we've all got Pentium 4's with at least 60-80 gig hard drives, right? ;)

Do a fresh install of d2 and LOD. Patch to 1.09d. Copy the entire d2 folder and paste it into a new folder called, for example, c:\Zy-El. Repeat this process for any other 1.09d mod that you're playing. Now patch the original d2 folder to 1.10. Copy the original d2 folder and paste the contents into as many new folders as you're planning on using for mods. My brother (d2vern) and I use this process and it works flawlessly.
I'd like to apologize in advance for anything that I may say or do that could be construed as offensive as I slowly go NUTS. - Colonel O'Neill

I'm telling you, Teal'c. If we don't find a way out of this soon, I'm gonna' lose it.
"Lose it. " It means, "Go crazy. " "Nuts. " "Insane. " "Bonzo. " "No longer in possession of one's faculties. " "Three fries short of a Happy Meal. " "Wacko. "

User avatar
Koolaid
Posts: 57
Joined: Tue Feb 11, 2003 1:16 pm
Location: Edmonton, Alberta

Re: V1.10 and V1.09 on same PC

Post by Koolaid » Mon May 16, 2005 3:00 am

I just have 2 sets of the files and use a couple of batch files to swap between 1.09b and 1.10.. Then i just put mod files in the d2 folder(if its mpq or dll edits) depending on which mod I play. I have used this method ever since 1.10 came out.

Simple and works well. Some of my friends us this method as well.

[Edit] Removed download.. I don't want to confuse anyone with 10 different ways to do the same thing :oops:
Last edited by Koolaid on Mon May 16, 2005 3:17 am, edited 2 times in total.
I am not a Geek. I am a level 12 Paladin.

User avatar
Elad
Forum Regular
Angel
Posts: 518
Joined: Tue Jan 21, 2003 3:41 am
Location: Florida
United States of America

Re: V1.10 and V1.09 on same PC

Post by Elad » Mon May 16, 2005 3:08 am

???Where does the renamed copy of game go. Zy El folder, or remain in original D2 folder and just use the short cut to the new game.exe. I had been using the many folders idea. With the entire game for each mod in it's own folder. Due to my own stupidity had game characters scattered every where.
Elad

User avatar
Myhrginoc
Retired Admin
Cherub
Posts: 12062
Joined: Sat May 25, 2002 7:28 am
Location: Percussion U

Hand-picked

Re: V1.10 and V1.09 on same PC

Post by Myhrginoc » Tue May 17, 2005 2:05 am

Game109d.exe stays in the Diablo II folder, next to the 1.10 version game.exe. But the 1.09 dlls go in the mod folder, to be superseded by the mod version of dlls and other mod files.
Do the right thing. It will gratify some people and astonish the rest.
~ Mark Twain
Run Diablo II in any version for mods: tutorial
The Terms of Service!! Know them, abide by them, and enjoy the forums at peace.
The Beginner's Guide v1.4: (MS Word | PDF) || Mod Running Scripts || TFW: Awakening

User avatar
Elad
Forum Regular
Angel
Posts: 518
Joined: Tue Jan 21, 2003 3:41 am
Location: Florida
United States of America

Re: V1.10 and V1.09 on same PC

Post by Elad » Tue May 17, 2005 3:33 am

Thanks :) I now have 3 folders. one with the original 109 dll's, one with the 109dll' modified by the Zy- El changes, and the D2 folder with dll's, and other files, this includes 2 game executes--109dgame.exe, and game.
Does the upgrade to 110 go in this latter folder?
Elad

User avatar
Myhrginoc
Retired Admin
Cherub
Posts: 12062
Joined: Sat May 25, 2002 7:28 am
Location: Percussion U

Hand-picked

Re: V1.10 and V1.09 on same PC

Post by Myhrginoc » Wed May 18, 2005 3:35 am

You should have a main directory created by the Blizzard installer, most likely

C:\Program files\Diablo II

in which you should have game109b.exe, game109d.exe and game.exe (this last being the 1.10 version). You will also have the 1.10 versions of the DLLs and patch_D2.mpq

You should also have a Backup109b and Backup109d subdirectory (these are suggested names), each of which has copies of that version's DLLs and patch_D2.mpq. They can be anywhere, since they aren't used by the game in any version. (If you only run 109b or 109d, you don't need the gameXXX.exe and backup directory for the other version.)

Now you need a Zy-El directory. Copy either 109b or 109d files from the appropriate backup directory, and install Zy-El on top of this. Or, if you already installed Zy-El, then copy the DLLs from the backup directory but don't overwrite the Zy-El DLLs.
Do the right thing. It will gratify some people and astonish the rest.
~ Mark Twain
Run Diablo II in any version for mods: tutorial
The Terms of Service!! Know them, abide by them, and enjoy the forums at peace.
The Beginner's Guide v1.4: (MS Word | PDF) || Mod Running Scripts || TFW: Awakening

joris
Posts: 28
Joined: Mon Apr 28, 2003 4:43 pm

Re: V1.10 and V1.09 on same PC

Post by joris » Tue Jun 28, 2005 5:17 pm

[quote=Tanis788";p="224424"]Can someone direct me to a file that allows me to change me versions from 1.10 to 1.09 and back. I've had it before but i want to be able to play both versions and test this mod.[/quote]

http://www.dark.uwhost2.net/files/reverter.zip

User avatar
PhrozenDragon
Posts: 95
Joined: Tue Jul 26, 2005 11:14 am

Re: V1.10 and V1.09 on same PC

Post by PhrozenDragon » Tue Jul 26, 2005 11:33 am

I tried to have 1.10 installed,and the 1.09d files in the Zy El folder. In the Zy El folder I have the Dll's, the MPQ, and the Zy El files. I did not overwrite them. I my Diablo directory, I have a game.exe copy named game109d. (that's the one with no image, right?) And my shortcut:
Target: "C:\Program\Diablo II\Game109d.exe"
Start in: "C:\Program\Diablo II\ZyEl"

But when I start the game and press Singleplayer, the game freezes and I get this message:

UNHANDLED EXCEPTION:
ACCESS_VIOLATION (c0000005)

When I close it the game shuts down

What have I done wrong?
Last edited by PhrozenDragon on Tue Jul 26, 2005 11:34 am, edited 1 time in total.

MickyBIs
Posts: 34
Joined: Mon Apr 05, 2004 1:41 am

Re: V1.10 and V1.09 on same PC

Post by MickyBIs » Tue Jul 26, 2005 6:52 pm

I remember hearing that the "Start in" function does not apply to DLLs, only to other game files. If you download the mod running scripts from the File Center, they can be modified slightly to launch 1.09 and 1.09 mods.
To modify them, right click on the script and select "edit", not open. It doesn't matter too much what you use to edit them, so long as it has a search/replace function. Once open, search for game.exe, and replace every instance with Game109d.exe. Drop the edited file into your Zyel folder, and it should be good to go.
I just tested the shortcut method out, and it definitely doesn't work, but my Zyel installation works great with the script. Hope that's all understandable and helpful, and happy zyeling!

McikyBIs

User avatar
PhrozenDragon
Posts: 95
Joined: Tue Jul 26, 2005 11:14 am

Re: V1.10 and V1.09 on same PC

Post by PhrozenDragon » Tue Jul 26, 2005 10:32 pm

Where do I get those from the file center?

MickyBIs
Posts: 34
Joined: Mon Apr 05, 2004 1:41 am

Re: V1.10 and V1.09 on same PC

Post by MickyBIs » Wed Jul 27, 2005 3:30 am

Here is a direct link. Good luck with it!

MickyBIs

User avatar
PhrozenDragon
Posts: 95
Joined: Tue Jul 26, 2005 11:14 am

Re: V1.10 and V1.09 on same PC

Post by PhrozenDragon » Wed Jul 27, 2005 9:42 am

I changed the three lines containing game.exe in the launchmodgame to game109d.exe, and the two in recover from crash. When I start from launchmodgame, it asks if I want to generate bin files, or play in windowed, and then it says it couldn't find the number 289 in the dll file Storm.dll.

User avatar
Myhrginoc
Retired Admin
Cherub
Posts: 12062
Joined: Sat May 25, 2002 7:28 am
Location: Percussion U

Hand-picked

Re: V1.10 and V1.09 on same PC

Post by Myhrginoc » Fri Jul 29, 2005 1:38 am

What is the version date of that storm.dll? There are several different copies floating around. If you don't have all 1.09x files in the Zy-El directory, it will try to get missing files from your Diablo II directory --- which if you have 1.10 installed it will conflict with your 1.09 setup.

For Zy-El, just answer NO to either question. Those are for mods that require you to generate your own bins (e.g. Middle Earth mod) and debugging.
Do the right thing. It will gratify some people and astonish the rest.
~ Mark Twain
Run Diablo II in any version for mods: tutorial
The Terms of Service!! Know them, abide by them, and enjoy the forums at peace.
The Beginner's Guide v1.4: (MS Word | PDF) || Mod Running Scripts || TFW: Awakening

User avatar
PhrozenDragon
Posts: 95
Joined: Tue Jul 26, 2005 11:14 am

Re: V1.10 and V1.09 on same PC

Post by PhrozenDragon » Fri Jul 29, 2005 2:45 pm

Thanks, but it's not needed. I made an entire new folder for Zy El.

Post Reply

Return to “Zy-El: Trial by Fire”