1.11 to 1.09d revert instructions

Information and updates for the Zy-El mod. If you have any questions or suggestions for the mods, please post them here. Click here to visit the official web site.

Moderators: Kato, d2vern

User avatar
Liveundead
Posts: 13
Joined: Wed Mar 22, 2006 5:13 am

1.11 to 1.09d revert instructions

Post by Liveundead » Wed Mar 22, 2006 5:47 am

Hello, I had some difficulty personally figuring out how to revert from 1.11 to 1.09d. So I have decided to post very specific instructions on how to accomplish this without uninstalling the game, and with the ability to easily convert from one version to annother without having to deal with scripts and the like ( I have no patience for coding ):

First, you will need the following tools.

1) Patch v 1.09d available at Blizz's patch site.
2) Any other patches you'd like to play, including up to the most recent version if you'd like to play on B-net.
3) WinMPQ avilaible here at the phrozen keep.

Now, open and extract the WinMPQ zip into it's own folder, attempt to run it. If it fails, then install the VBfiles that come in the zip. Once you get it working, you need to navigate to the d2char.MPQ file in the DII folder on your hard disk and open it. Once opened, a long list of files should appear in the box, scroll toward the bottom of the list. Here you'll find a game.exe of a version low enough that you'll be able to load any patch file you like. Extract this game.exe to your desktop.

Before proceeding, if you would like to have a backup of this version of the game, packup all of the .dlls, mpqs and that version of game.exe into a folder named after that patch version of DII.

Now, take the game.exe from your desktop and over-write the current file in the DII directory. Run the next lowest patch you want to play, and back it up into a folder the same way as described above. Rinse and repeat running patches and backing up folders for every version you would like to play.

From here on, inorder to change version all that needs be done is a simple copy/paste from the folder you'd like to play into the DII directory. No running of patches required untill the next update. No need for confusing scripts.

An even easier way of handling mods using the same method: If you only want to play one mod per patch version. ( Say, you have no other mods besides Zyel that you'd want to play with version 1.09d ) you can copy the Zyel files directly into the 1.09d folder and rename it to the mod, and switch versions and mods in one simple copy/paste.


Special note about the game.exe available for download on Blizz's patch site: It's version number is 1.0.9.3. v1.09d's game.exe version number is 1.0.9.2, it is impossible to use this game.exe to patch below version 1.10.

Also, as far as I can tell, it is impossible to extract a game.exe from the C.D. Roms or any of the patchs themselves.

I've seen several posts on this topic across the site, and even found a tutorial. The tutorial was a bit weak on a few key points, which took me a while to figure out. Hope this is helpful to people.

Later.

User avatar
d2vern
Retired staff
Angel
Posts: 647
Joined: Wed Dec 10, 2003 3:13 am
Location: Portland, Oregon

Re: 1.11 to 1.09d revert instructions

Post by d2vern » Wed Mar 22, 2006 9:49 pm

Welcome to the forums.

This is a nice set of instructions for reversion. Just make sure that you keep separate folders for each version, keeping a game.exe for each version in the mod folder.
God of Zy-El since 2009. Active member of Mentaldom since 2007. Prone to taking extended dog naps. Kato is the cat, I'm the dog, Al-T is a tiger (cub), Hans is a Bee Gee look-alike and German porn star. Together, we are the Gods of Zy-El!

Kato: Supreme God. Maker of the World since 2003.
Al-T: Godling. Top poster and Mod-in-Training since 2006
Hans: Godling. German porn star and Bee Gee lookalike since 2006.

User avatar
Myhrginoc
Retired Admin
Cherub
Posts: 12062
Joined: Sat May 25, 2002 7:28 am
Location: Percussion U

Hand-picked

Re: 1.11 to 1.09d revert instructions

Post by Myhrginoc » Thu Mar 23, 2006 3:54 am

Also, as far as I can tell, it is impossible to extract a game.exe from the C.D. Roms or any of the patchs themselves.
You can extract it from d2char.mpq using WinMPQ and an up-to-date datafile.
I've seen several posts on this topic across the site, and even found a tutorial. The tutorial was a bit weak on a few key points, which took me a while to figure out.
I am always in favor of improvement, can you please be more specific about the tutorial's weakness(es)? Feel free to PM me since we probably should keep this thread more oriented toward Zy-El.
Last edited by Myhrginoc on Thu Mar 23, 2006 3:55 am, edited 1 time in total.
Do the right thing. It will gratify some people and astonish the rest.
~ Mark Twain
Run Diablo II in any version for mods: tutorial
The Terms of Service!! Know them, abide by them, and enjoy the forums at peace.
The Beginner's Guide v1.4: (MS Word | PDF) || Mod Running Scripts || TFW: Awakening

User avatar
Al-T
Forum Legend
Power
Posts: 3704
Joined: Sun Mar 13, 2005 2:19 am

Re: 1.11 to 1.09d revert instructions

Post by Al-T » Thu Mar 23, 2006 11:10 am

From here on, inorder to change version all that needs be done is a simple copy/paste from the folder you'd like to play into the DII directory.
This is the method I use but as copying and pasting does not always guarantee 100% success (you sometimes have to delete the existing patch_d2.mpq and then install the mod version), I have a set of batch files set up to delete the "current" files then copy over the mod files. One batch file for each mod and for vanilla1.09D/1.10/1.11/1.11b. The batch files are on my toolbar so two clicks does the job.

One other thing you have to be careful of here is if you are using PlugY, especially different versions (different mods may use different versions), you need to be sure you have the correct PlugY.ini file with the appropriate settings for any particular mod. I just use version 7.01 of PlugY for vanilla and the mods that don't have it incorporated and just use the version that comes incorporated in the others but have different .ini files for each mod with their various settings so that the characters are all saved in the appropriate folders.

[EDIT] The Game.exe version I use is 1.0.0.1 and have not had any problems with it so far.
Last edited by Al-T on Sun Mar 04, 2007 6:06 pm, edited 2 times in total.
Al-Tisaur...Card carrying member of mentaldom since March 2007 & "Zy-Sensitive" Veteran Pension Holder!
Veteran? More like "Ancient Relic!"..been playing the mod for 12 years!
Trying to picture Al as a Power,... it's not working it must be the Tiger Stripes that get me every time - Hans
I get knocked down but I get up again, you're never gonna keep me down...!
Official Zy-El Website | ZyEl Wiki | Russian Zy-El Website by mahatmaQL | Eastern Sun

User avatar
Liveundead
Posts: 13
Joined: Wed Mar 22, 2006 5:13 am

Re: 1.11 to 1.09d revert instructions

Post by Liveundead » Sat Mar 25, 2006 12:13 pm

The weakness were thus:

The game.exe not allowing to patch before v1.10 on Blizz's website. And I couldn't find any instructions on using winMPQ aside from somehow I had to get it running and which file I had to look in. All fairly simple stuff, which was then solved relatively easily by just looking at what I had and applying some brain power, but it took a few minutes to think of each potential solution and try them out. I specifically laid all that out in the above post.

I didn't check the regular DII disk for the mpq after I had checked it originally for a game.exe, thanks for the tip though.

I figured plugY would work like that, I just have all of the files that came with the mod in the folder 100%, and copy and paste them over. I delete the plugy alltogether when I wanna play on B-Net though.. can't be too careful when it comes to what they might be looking for.

User avatar
Al-T
Forum Legend
Power
Posts: 3704
Joined: Sun Mar 13, 2005 2:19 am

Re: 1.11 to 1.09d revert instructions

Post by Al-T » Sat Mar 25, 2006 2:47 pm

I delete the plugy alltogether when I wanna play on B-Net though.. can't be too careful when it comes to what they might be looking for.
You don't need to do this. Plugy will do an automatic uninstall of the extra shared and personal pages without leaving any traces if you try to connect to battle.net. If you are playing vanilla 1.11b with PlugY installed and then try to connect to bnet without exiting the game first, you will get a message from PlugY saying you have to restart the game. This is in order that it can remove the extra pages and stash before connecting to bnet. Yohann is a stickler for this kind of thing and he himself is very much against cheating in any shape or form.
Al-Tisaur...Card carrying member of mentaldom since March 2007 & "Zy-Sensitive" Veteran Pension Holder!
Veteran? More like "Ancient Relic!"..been playing the mod for 12 years!
Trying to picture Al as a Power,... it's not working it must be the Tiger Stripes that get me every time - Hans
I get knocked down but I get up again, you're never gonna keep me down...!
Official Zy-El Website | ZyEl Wiki | Russian Zy-El Website by mahatmaQL | Eastern Sun

User avatar
Myhrginoc
Retired Admin
Cherub
Posts: 12062
Joined: Sat May 25, 2002 7:28 am
Location: Percussion U

Hand-picked

Re: 1.11 to 1.09d revert instructions

Post by Myhrginoc » Sat Mar 25, 2006 7:41 pm

Thanks for the tips. I added a note about the limitations of that downloadable game.exe from Blizzard (good back to v1.10 beta, it really is a v1.09e file). I also linked to the download page for the Beginner's Guide with references to relevant sections, as there are several ways to extract files from an mpq and it is outside of the scope of the tutorial to go into modmakers' tools.
Do the right thing. It will gratify some people and astonish the rest.
~ Mark Twain
Run Diablo II in any version for mods: tutorial
The Terms of Service!! Know them, abide by them, and enjoy the forums at peace.
The Beginner's Guide v1.4: (MS Word | PDF) || Mod Running Scripts || TFW: Awakening

Cyanide
Posts: 4
Joined: Sat Jul 01, 2006 10:33 pm

Re: 1.11 to 1.09d revert instructions

Post by Cyanide » Sun Jul 02, 2006 6:52 am

I can no get this to work. I followed the directions to the letter and the patcher still tells me it can't patch the game because it is for a different version. What am I missing?

User avatar
Myhrginoc
Retired Admin
Cherub
Posts: 12062
Joined: Sat May 25, 2002 7:28 am
Location: Percussion U

Hand-picked

Re: 1.11 to 1.09d revert instructions

Post by Myhrginoc » Sun Jul 02, 2006 4:44 pm

You may need to post more information about your setup. But I'll start by assuming you have a battle.net-ready default installation, meaning version 1.11b. You can use these plans as checklists to see if you missed a step.

Plan A

1) Make a subfolder called "v1.09 files" in your Diablo II folder.

2) Download Blizzard's game-lod.zipfile from their ftp site or follow the link to an official mirror site. Unzip in the new subfolder.

3) Download our v1.09d dll package and unzip in the new subfolder.

4) Copy game.exe and rename the copy game109e.exe. Move this copy to your Diablo II folder.

5a) You have Zy-El installed. Copy dlls from the storage folder to the Zy-El folder, but do not overwrite anything.

OR

5b) You don't have Zy-El installed. Make a Zy-El folder, copy from your v1.09 storage to the new Zy-El folder, then install the mod. Overwrite any dlls with ones from the mod package (4 total).

6) Find the file Launch Zy-El.vbs in your Zy-El folder. Right-click on the file name and choose EDIT (do not open the file or it will attempt to run Zy-El). Look for the line D2CmdLine = chr(34) & D2Path & "game.exe" & chr(34) & "-direct -txt" about halfway through the file and change the reference to game109e.exe.

7) Use the edited vbs file to start the mod.

Plan A might not work, if there is any incompatibility between v1.09e game.exe and v1.09d dlls. In that case, you need to do a little more work.

Plan B

1) Download a copy of MPQView and download our datafile.

2) Run MPQView. First load the datafile with File | Open datafile. Then load d2char.mpq with File | Open archive. d2char.mpq is in your Diablo II folder.

3) Look for game.exe in the archive file list, click on the name and extract it using the Save button. Put it in a new subfolder named "v1.07 files".

4) Copy the extracted game.exe on top of game.exe in your Diablo II folder.

5) Run the v1.09d patcher from Blizzard.

6) Make the subfolder v1.09d files". Copy game.exe, all dlls and patch_D2.mpq from your Diablo II folder to this new subfolder. Then copy game.exe within your Diablo II folder and call it "game109d.exe."

7a) You have Zy-El installed. Copy dlls from the storage folder to the Zy-El folder, but do not overwrite anything.

OR

7b) You don't have Zy-El installed. Make a Zy-El folder, copy dlls only from your v1.09 storage to the new Zy-El folder, then install the mod. Overwrite any dlls with ones from the mod package (4 total).

8) Find the file Launch Zy-El.vbs in your Zy-El folder. Right-click on the file name and choose EDIT (do not open the file or it will attempt to run Zy-El). Look for the line D2CmdLine = chr(34) & D2Path & "game.exe" & chr(34) & "-direct -txt" about halfway through the file and change the reference to game109d.exe.

9) Use the edited vbs file to start the mod.

10) It is now safe to run Blizzard's v1.11b patcher to restore your original v1.11b Diablo II.
Last edited by Myhrginoc on Sun Jul 02, 2006 4:52 pm, edited 2 times in total.
Do the right thing. It will gratify some people and astonish the rest.
~ Mark Twain
Run Diablo II in any version for mods: tutorial
The Terms of Service!! Know them, abide by them, and enjoy the forums at peace.
The Beginner's Guide v1.4: (MS Word | PDF) || Mod Running Scripts || TFW: Awakening

User avatar
petunia
Posts: 36
Joined: Tue Jul 01, 2008 5:02 pm

Post by petunia » Tue Jul 01, 2008 7:22 pm

omg...................... help i try to get the 1.09 patch from blizz site, there isnt one there, mind putting a link up on here?!?!?!?!? and when i try to get anyhting form this site, it says the connection has been reset and i connect, wtf is this all about, please help, really wanna play this game, but im that much into hacking, i dont know anything about this. Try writing this for a 3 year old, and it'd be better :D

User avatar
petunia
Posts: 36
Joined: Tue Jul 01, 2008 5:02 pm

Post by petunia » Tue Jul 01, 2008 7:23 pm

srry, it was supposed to be, "but im not that much into hacking"

User avatar
Hans
Dark Alliance Beta Test
Dominion
Posts: 6438
Joined: Sat Oct 02, 2004 5:14 pm
Location: Toronto, Ontario, Canada

Post by Hans » Tue Jul 01, 2008 8:09 pm

I think the blizzard site is experiencing a lot of traffic. Try again later.
"Hi. My name is Hans, and I am addicted to a game that is not yet been made" - Card carrying member of D3 Addictions Anonymous, since June 2008.
Card carrying member of Mentaldom, since May 2006 - Zy-El Hardcore.
"German pornstar/Bee Gee lookalike" & "The Blacksmith"
Trying to picture Hans as a Dominion...nah it isn't working sorry. It's the mustache that gets me every time - Al-T.
"All men play on 127" O-H - Hans
"Okay, time out. This is Zy-El. The mod of total excess. Since when would any Zy-El lover do only what's necessary?" - Metropolis Man
Zy-El Wiki|New Zy-El Website

User avatar
petunia
Posts: 36
Joined: Tue Jul 01, 2008 5:02 pm

Re: 1.11 to 1.09d revert instructions

Post by petunia » Tue Jul 01, 2008 11:44 pm

can anyone just send me the files/stuff i need???? please i really need help on this, i already said im not really much of a person that is good with this stuff.....please help me out....

User avatar
Kato
Retired staff
Virtue
Posts: 4335
Joined: Mon Jun 03, 2002 4:36 pm
Location: Somewhere out there beyond the pale blue moon

Re: 1.11 to 1.09d revert instructions

Post by Kato » Wed Jul 02, 2008 1:20 am

:cool: Okay, let's do this the simple way. BTW, Blizzard no longer hosts the patch 1.09d installer.

:arrow: Un-install Diablo2: Lord Destruction (which got patched up to patch 1.12a when you connected to Battle.net and does not work with Zy-El)

:arrow: Re-install Diablo2: Lord of Destruction from your install CD. This will be the stock patch 1.07.

:arrow: Download the patch 1.09d installer from here: http://www.moddb.com/mods/zy-el-trial-b ... -installer

:arrow: Install patch 1.09d.

:arrow: Go through the Zy-El mod zip file and delete the same .DLL's from your Diablo2 game directory.

:arrow: Delete the patch_d2.MPQ from your Diablo2 game directory.

:arrow: Install the Zy-El .DLL's and .MPQ file into the your Diablo2 game directory.

:arrow: Done. Play the Zy-El mod by starting Diablo2 as you normally would.
Last edited by Kato on Wed Jul 02, 2008 1:22 am, edited 1 time in total.
"Do not be too proud of this technological terror you've constructed." - D.Vader
Zy-El: Trial by Fire Mod Forum: http://phrozenkeep.it-point.com/forum/v ... m.php?f=53
Zy-El website: http://www3.telus.net/zyel/index.html Zy-El wiki: http://zyel.wikispaces.com/

User avatar
gagless
Posts: 2
Joined: Tue Feb 03, 2009 9:40 pm

Re: 1.11 to 1.09d revert instructions

Post by gagless » Tue Feb 03, 2009 9:48 pm

Anyone know how to do this on Mac OS X 10.4? I have 1.12 installed and running but would like to go back to 1.09...

User avatar
gagless
Posts: 2
Joined: Tue Feb 03, 2009 9:40 pm

Re: 1.11 to 1.09d revert instructions

Post by gagless » Tue Feb 03, 2009 9:48 pm

My apologies for the double post...
Last edited by gagless on Tue Feb 03, 2009 9:51 pm, edited 1 time in total.

User avatar
Hans
Dark Alliance Beta Test
Dominion
Posts: 6438
Joined: Sat Oct 02, 2004 5:14 pm
Location: Toronto, Ontario, Canada

Post by Hans » Wed Feb 04, 2009 4:17 pm

I think you would have to install D2 again. Do you have the CDs or did you purchase online from Blizzard. If you purchased from Blizzard Online you might be out of luck.
"Hi. My name is Hans, and I am addicted to a game that is not yet been made" - Card carrying member of D3 Addictions Anonymous, since June 2008.
Card carrying member of Mentaldom, since May 2006 - Zy-El Hardcore.
"German pornstar/Bee Gee lookalike" & "The Blacksmith"
Trying to picture Hans as a Dominion...nah it isn't working sorry. It's the mustache that gets me every time - Al-T.
"All men play on 127" O-H - Hans
"Okay, time out. This is Zy-El. The mod of total excess. Since when would any Zy-El lover do only what's necessary?" - Metropolis Man
Zy-El Wiki|New Zy-El Website

User avatar
iamgodtier
Posts: 42
Joined: Sat Jul 25, 2009 8:43 pm

Re: 1.11 to 1.09d revert instructions

Post by iamgodtier » Thu Sep 17, 2009 9:57 pm

I know i'm new here... and i'm not sure if this is allowed... if it's not please let me know so i can remove it.

1.1X > 1.09 The Easy Way:
http://rapidshare.com/files/281484470/110to109.zip.html
md5: 1FD4C0DEF9806270AADF79C165304E93

Step 1: backup your current diablo 2 folder if at all possible since i did not bother to make a BAT conversion
Step 2: Download file above and extract to your desired folder that will have Zy-El
Step 3: Extract the contents of the zy-el mod into the folder where you extracted "110to109.zip"
Step 4: Rejoice

Step 1 is optional.
Last edited by iamgodtier on Fri Sep 18, 2009 7:55 pm, edited 2 times in total.

User avatar
Hans
Dark Alliance Beta Test
Dominion
Posts: 6438
Joined: Sat Oct 02, 2004 5:14 pm
Location: Toronto, Ontario, Canada

Re: 1.11 to 1.09d revert instructions

Post by Hans » Fri Sep 18, 2009 6:58 pm

iamgodtier it will depend what is in the file. I would suggest to remove it for the time being and pm Onyx if it is alright to be posted.
"Hi. My name is Hans, and I am addicted to a game that is not yet been made" - Card carrying member of D3 Addictions Anonymous, since June 2008.
Card carrying member of Mentaldom, since May 2006 - Zy-El Hardcore.
"German pornstar/Bee Gee lookalike" & "The Blacksmith"
Trying to picture Hans as a Dominion...nah it isn't working sorry. It's the mustache that gets me every time - Al-T.
"All men play on 127" O-H - Hans
"Okay, time out. This is Zy-El. The mod of total excess. Since when would any Zy-El lover do only what's necessary?" - Metropolis Man
Zy-El Wiki|New Zy-El Website

User avatar
iamgodtier
Posts: 42
Joined: Sat Jul 25, 2009 8:43 pm

Re: 1.11 to 1.09d revert instructions

Post by iamgodtier » Fri Sep 18, 2009 7:47 pm

Hans" wrote:iamgodtier it will depend what is in the file. I would suggest to remove it for the time being and pm Onyx if it is alright to be posted.
1.09 dll files
1.09 game.exe
1.09 diabloII.exe

NO mpqs.

User avatar
Hans
Dark Alliance Beta Test
Dominion
Posts: 6438
Joined: Sat Oct 02, 2004 5:14 pm
Location: Toronto, Ontario, Canada

Re: 1.11 to 1.09d revert instructions

Post by Hans » Fri Sep 18, 2009 7:50 pm

I would still check with Onyx since it has 1.09 game.exe and the 1.09 diabloii.exe
"Hi. My name is Hans, and I am addicted to a game that is not yet been made" - Card carrying member of D3 Addictions Anonymous, since June 2008.
Card carrying member of Mentaldom, since May 2006 - Zy-El Hardcore.
"German pornstar/Bee Gee lookalike" & "The Blacksmith"
Trying to picture Hans as a Dominion...nah it isn't working sorry. It's the mustache that gets me every time - Al-T.
"All men play on 127" O-H - Hans
"Okay, time out. This is Zy-El. The mod of total excess. Since when would any Zy-El lover do only what's necessary?" - Metropolis Man
Zy-El Wiki|New Zy-El Website

User avatar
iamgodtier
Posts: 42
Joined: Sat Jul 25, 2009 8:43 pm

Re: 1.11 to 1.09d revert instructions

Post by iamgodtier » Fri Sep 18, 2009 7:54 pm

Hans" wrote:I would still check with Onyx since it has 1.09 game.exe and the 1.09 diabloii.exe
Edit: re-upped the link

mygh is of the same rank that onyx is... and he posted a link to the 1.09d DLL and a link to blizzard's FTP for the game.exe
Last edited by iamgodtier on Fri Sep 18, 2009 7:57 pm, edited 1 time in total.

User avatar
Hans
Dark Alliance Beta Test
Dominion
Posts: 6438
Joined: Sat Oct 02, 2004 5:14 pm
Location: Toronto, Ontario, Canada

Re: 1.11 to 1.09d revert instructions

Post by Hans » Fri Sep 18, 2009 7:56 pm

Then it should be fine.
"Hi. My name is Hans, and I am addicted to a game that is not yet been made" - Card carrying member of D3 Addictions Anonymous, since June 2008.
Card carrying member of Mentaldom, since May 2006 - Zy-El Hardcore.
"German pornstar/Bee Gee lookalike" & "The Blacksmith"
Trying to picture Hans as a Dominion...nah it isn't working sorry. It's the mustache that gets me every time - Al-T.
"All men play on 127" O-H - Hans
"Okay, time out. This is Zy-El. The mod of total excess. Since when would any Zy-El lover do only what's necessary?" - Metropolis Man
Zy-El Wiki|New Zy-El Website

User avatar
d2vern
Retired staff
Angel
Posts: 647
Joined: Wed Dec 10, 2003 3:13 am
Location: Portland, Oregon

Re: 1.11 to 1.09d revert instructions

Post by d2vern » Sun Apr 10, 2011 2:21 am

Argh! The new xpac disc carries the 1.12 patch. I need to revert to 1.09d. Give me a break and help!
God of Zy-El since 2009. Active member of Mentaldom since 2007. Prone to taking extended dog naps. Kato is the cat, I'm the dog, Al-T is a tiger (cub), Hans is a Bee Gee look-alike and German porn star. Together, we are the Gods of Zy-El!

Kato: Supreme God. Maker of the World since 2003.
Al-T: Godling. Top poster and Mod-in-Training since 2006
Hans: Godling. German porn star and Bee Gee lookalike since 2006.

User avatar
ChaosMarc
Dark Alliance Beta Test
Paladin
Posts: 232
Joined: Fri May 28, 2004 2:00 pm
Germany

Re: 1.11 to 1.09d revert instructions

Post by ChaosMarc » Sun Apr 10, 2011 8:13 am

grab my Versionchanger, unpack it to your diablo 2 path, run versionchanger.bat, choose "1", hit enter, voila :)

or downloadLOD_109d.exe from blizzards ftp (maybe you have to reload the page a few times until it loads). unpack game.exe from your d2char.mpq (described in the first post) to your diablo 2 folder and overwrite existing game.exe. now run LOD_109d.exe, voila :)
Last edited by ChaosMarc on Sun Apr 10, 2011 12:10 pm, edited 2 times in total.

Post Reply

Return to “Zy-El: Trial by Fire”