[solved] act 5 mapclone in act 1 behaves like its in act 5

Post here for all aspects of map making and level design. Click here to visit the Keep's official map site, Diabolic Cartography.

Moderator: Paul Siramy

Post Reply
sonic
Junior Member
Paladin
Posts: 121
Joined: Tue Jul 24, 2012 12:15 pm

[solved] act 5 mapclone in act 1 behaves like its in act 5

Post by sonic » Tue Mar 25, 2014 5:56 pm

hi guys im new into mapmodding and after over 8 hours... i got something working

Diablo 2 CACHE?
is there something that beside of the patch_d2.mpq and the -direct -txt through the "data" modding folder
gets information from somewhere else that ignores a part of the mod since "it knows" what a part of the mod it already saw to make the game i guess execute faster (the problem is that things have changed since then but it uses the old part)?
my problem is listed below which is solved by now

EDIT: great. my m8 made the same thing worked for him fine
he sent me his:
data folder
patch_d2.mpq (clean 1.13c)
and even the save game
to get the effect of a perfect copy

i have replaced all that and i still got the error,
restarted PC
and still same error.
i just don't get it.
we checked all DLL files if there is any difference between his and my,
checked the exe
checked shortcuts tried both xp and native win7 mode, also he is on win7
and probably a few more things that don't come in my mind right now,


after he made the modded patch_d2.mpq it magically started working on my
side and since then i successfully replaced the data folder with my custom one and the patch with my custom one also.
and it just started all working.

and i am sure that i have not made a mistake before i must of checked the lvlprest and levels missiles probably about 30 times each.




the unknown self solved issue
what i thought,


(8 hours probably cause i have tried to enter it with a red portal (from act1 and as well tried act5) that didn't work with the level probably because as the title says. (now thinking cache?) btw after entering the level i was able to cast the red portal inside the level so that 2 portals opened almost next to eachother there which also worked fine.)

my issue was that i got a new map in act 1 that behaves very weird.
its a clone of arreat summit (mountain top mtntop.ds1)
i have set the waypoint of cold plains to the new map after failing with the red portal for testing atm, it will be removed later and a trapdoor placed.
some weired behaviour: (gets better at the bottom)
entering the game act 1 entering new waypoint works fine.
entering the game (act 2-5) entering the waypoint to new level i get C000005 error
entering the game (act 2-5) taking waypoint to act 1 town, then to new area and it works every time.
entering the game (act 2-5) going to act 1 town going to act (2-5) then taking waypoint to new area works fine

so i guess once i have been in act 1 before then i can enter the new map waypoint from any act.
so placing a trapdoor from act 1 town to the new area should fix that matter BUT

now the more weird part.
entering act 1 new map, using town portal scroll which gets me right to harrogath.
also when entering the waypoint on the new map opens by default act 5 waypoint menu.
having a different "Entyfile" (levels.txt column) other then act 5 gives me the C0000005 error

other issues:
entering the new map via waypoint does not place me on the other waypoint just in the middle of the map (there is nothing in the DS1 file to place me there but it does it every time)
the "map entry special" has also been placed somewhere else



Levels.txt and LvlPrest.txt edits.

levels.txt
cloned mountain top edits:
changed name
ID (to 137)
Act (from 4 to 0)
removed all vis and warp
changed levelname and levelwarp
Entryfile if i change it to anything that is not Act5 it crashes.

put zero in the following columns
MonLvl (1,2,3) and MonLvlEx (1,2,3) and MonDen (norm, night,hell) and NumMon
removed acientbarbs from the column

LvlPrest:
cloned act 5 baal entrance (file column: expansion\mountaintop\mtntop.ds1)
changed:
name
def (to 1091)
LevelID (to 137)
SizeX 0
SizeY 0
navigated file1 to the correct location




mapedits
(mtntop.ds1)
deleted:
the barbarians
the object that activates them
both entrance
and all the boxes with some random numbers in it :neutral:

placed:
map entrance (doesn't work)
waypoint (when entering to the new level i don't land on the waypoint just way off)

Behavior now:
casting red portal in act 1 gets me right to the new arena works perfect.
opening town portal from new area gets me right to act 1 town :)
waypoint is accessible from any act and doesn't cause crashes any more ( don't need the waypoint anyway will be removed)

Post Reply

Return to “Map Editing”