KOT crash after killing Diablo

Information and updates for the Kingdom of Tenai mod. If you have any questions or suggestions for the mod, please post them here. Click here to visit the official web site.

Moderator: Vegabond_635

Post Reply
soulofdeath
Posts: 1
Joined: Sat Apr 18, 2020 12:22 pm
Bulgaria

KOT crash after killing Diablo

Post by soulofdeath » Sat Apr 18, 2020 12:27 pm

Hello guys i need a little help,
when i kill Diablo at act 4 and go to talk with the Angel in town to open red portal to act5 game crash with entering the portal every time... i play with elementalist druid if it has a matter

User avatar
HarvestWombs
Senior Moderator
Arch-Angel
Posts: 1001
Joined: Wed May 25, 2011 11:50 pm
United States of America

Re: KOT crash after killing Diablo

Post by HarvestWombs » Sat Apr 18, 2020 4:04 pm

This mod has been unsupported for nearly 15 years.
Official Phrozen Keep Discord
Common Modding tools: link
My Resource Packs: link

User avatar
Cypress
Posts: 58
Joined: Fri Dec 01, 2017 2:08 am

Re: KOT crash after killing Diablo

Post by Cypress » Sat Apr 18, 2020 8:46 pm

What version of KoT are you playing and what version of Diablo 2? KoT 1.13a is meant for Diablo 2 1.10f. And if you are running it via D2SE, be sure you are loading the D2CustomTbl.dll under the ModDll section and have D2Extra=1.

Also only somewhat related, but you should be aware that the Baal waves are very broken in this mod, with the final wave crashing the game if you kill them (you have to lure them out of the throne room instead or suffer).

dimitarvichev93
Posts: 6
Joined: Mon Jun 01, 2020 10:22 pm

Re: KOT crash after killing Diablo

Post by dimitarvichev93 » Mon Jun 01, 2020 10:26 pm

mee to how to fix this?

dimitarvichev93
Posts: 6
Joined: Mon Jun 01, 2020 10:22 pm

Re: KOT crash after killing Diablo

Post by dimitarvichev93 » Mon Jun 01, 2020 11:01 pm

Cypress wrote:
Sat Apr 18, 2020 8:46 pm
What version of KoT are you playing and what version of Diablo 2? KoT 1.13a is meant for Diablo 2 1.10f. And if you are running it via D2SE, be sure you are loading the D2CustomTbl.dll under the ModDll section and have D2Extra=1.

Also only somewhat related, but you should be aware that the Baal waves are very broken in this mod, with the final wave crashing the game if you kill them (you have to lure them out of the throne room instead or suffer).
how to do this?

User avatar
Cypress
Posts: 58
Joined: Fri Dec 01, 2017 2:08 am

Re: KOT crash after killing Diablo

Post by Cypress » Tue Jun 02, 2020 12:32 am

What version of Kingdom of Tenai are you running? Where did you download it from? Are you running it through D2SE or no? What game version of Diablo 2 are you running it from? Are you having the same problem of crashing at the Act 4 portal?

dimitarvichev93
Posts: 6
Joined: Mon Jun 01, 2020 10:22 pm

Re: KOT crash after killing Diablo

Post by dimitarvichev93 » Tue Jun 02, 2020 5:19 am

Cypress wrote:
Tue Jun 02, 2020 12:32 am
What version of Kingdom of Tenai are you running? Where did you download it from? Are you running it through D2SE or no? What game version of Diablo 2 are you running it from? Are you having the same problem of crashing at the Act 4 portal?
Diablo.II.v1.14d.Lord.of.Destruction-GGn

User avatar
Cypress
Posts: 58
Joined: Fri Dec 01, 2017 2:08 am

Re: KOT crash after killing Diablo

Post by Cypress » Tue Jun 02, 2020 1:48 pm

This mod is meant for Diablo 2 version 1.10f. Any other version will have problems. Either downgrade to 1.13c and install D2SE then download Kingdom of Tenai for D2SE, or install Cactus (which does work for 1.14d) and add Kingdom of Tenai as a mod.

If you choose to go with the Cactus route:
1) You will need to make a separate mod folder for Kingdom of Tenai, which you will extract the mod into
2) Download PlugY and place it into the same folder
3) Copy the contents of Cactus's 1.10f folder into the Kingdom of Tenai folder (don't replace anything)
4) Go into Plugy.ini and set "DllToLoad=D2Extra.dll" and "DllToLoad2=D2CustomTbl.dll".
5) Be sure to tell Cactus to run off PlugY.exe and not Game.exe for this mod (since you need to run it via PlugY.exe to initiate D2Extra.dll and D2CustomTbl.dll)

If you plan on playing a lot of mods, I'd recommend just downgrading and installing D2SE since it is a lot easier to use than Cactus.

dimitarvichev93
Posts: 6
Joined: Mon Jun 01, 2020 10:22 pm

Re: KOT crash after killing Diablo

Post by dimitarvichev93 » Tue Jun 02, 2020 3:20 pm

Cypress wrote:
Tue Jun 02, 2020 1:48 pm
This mod is meant for Diablo 2 version 1.10f. Any other version will have problems. Either downgrade to 1.13c and install D2SE then download Kingdom of Tenai for D2SE, or install Cactus (which does work for 1.14d) and add Kingdom of Tenai as a mod.

If you choose to go with the Cactus route:
1) You will need to make a separate mod folder for Kingdom of Tenai, which you will extract the mod into
2) Download PlugY and place it into the same folder
3) Copy the contents of Cactus's 1.10f folder into the Kingdom of Tenai folder (don't replace anything)
4) Go into Plugy.ini and set "DllToLoad=D2Extra.dll" and "DllToLoad2=D2CustomTbl.dll".
5) Be sure to tell Cactus to run off PlugY.exe and not Game.exe for this mod (since you need to run it via PlugY.exe to initiate D2Extra.dll and D2CustomTbl.dll)

If you plan on playing a lot of mods, I'd recommend just downgrading and installing D2SE since it is a lot easier to use than Cactus.
can you give me the link lith diablo 2 so i can downloadet

dimitarvichev93
Posts: 6
Joined: Mon Jun 01, 2020 10:22 pm

Re: KOT crash after killing Diablo

Post by dimitarvichev93 » Wed Jun 03, 2020 6:16 pm

Cypress wrote:
Tue Jun 02, 2020 1:48 pm
This mod is meant for Diablo 2 version 1.10f. Any other version will have problems. Either downgrade to 1.13c and install D2SE then download Kingdom of Tenai for D2SE, or install Cactus (which does work for 1.14d) and add Kingdom of Tenai as a mod.

If you choose to go with the Cactus route:
1) You will need to make a separate mod folder for Kingdom of Tenai, which you will extract the mod into
2) Download PlugY and place it into the same folder
3) Copy the contents of Cactus's 1.10f folder into the Kingdom of Tenai folder (don't replace anything)
4) Go into Plugy.ini and set "DllToLoad=D2Extra.dll" and "DllToLoad2=D2CustomTbl.dll".
5) Be sure to tell Cactus to run off PlugY.exe and not Game.exe for this mod (since you need to run it via PlugY.exe to initiate D2Extra.dll and D2CustomTbl.dll)

If you plan on playing a lot of mods, I'd recommend just downgrading and installing D2SE since it is a lot easier to use than Cactus.
man i find diablo 2 1.10f do it all and dont work .... :S

dimitarvichev93
Posts: 6
Joined: Mon Jun 01, 2020 10:22 pm

Re: KOT crash after killing Diablo

Post by dimitarvichev93 » Wed Jun 03, 2020 6:57 pm

dimitarvichev93 wrote:
Wed Jun 03, 2020 6:16 pm
Cypress wrote:
Tue Jun 02, 2020 1:48 pm
This mod is meant for Diablo 2 version 1.10f. Any other version will have problems. Either downgrade to 1.13c and install D2SE then download Kingdom of Tenai for D2SE, or install Cactus (which does work for 1.14d) and add Kingdom of Tenai as a mod.

If you choose to go with the Cactus route:
1) You will need to make a separate mod folder for Kingdom of Tenai, which you will extract the mod into
2) Download PlugY and place it into the same folder
3) Copy the contents of Cactus's 1.10f folder into the Kingdom of Tenai folder (don't replace anything)
4) Go into Plugy.ini and set "DllToLoad=D2Extra.dll" and "DllToLoad2=D2CustomTbl.dll".
5) Be sure to tell Cactus to run off PlugY.exe and not Game.exe for this mod (since you need to run it via PlugY.exe to initiate D2Extra.dll and D2CustomTbl.dll)

If you plan on playing a lot of mods, I'd recommend just downgrading and installing D2SE since it is a lot easier to use than Cactus.
can you tell more about cactus to try just say describe it in simpler words because I don't understand English well

User avatar
Cypress
Posts: 58
Joined: Fri Dec 01, 2017 2:08 am

Re: KOT crash after killing Diablo

Post by Cypress » Fri Jun 05, 2020 1:53 pm

dimitarvichev93 wrote:
Wed Jun 03, 2020 6:16 pm
man i find diablo 2 1.10f do it all and dont work .... :S
I don't recommend running it directly off 1.10f, it is a lot harder to run mods that way.

Instead, if you managed to downgrade to 1.10f, then you can upgrade to 1.13c from there and install D2SE, then download this and put it into your mods folder. D2SE plugins are setup so that all the installation problems are already done.

Also, you do not need to make multiple posts in a row, editing your post will bump the thread.

Post Reply

Return to “Kingdom of Tenai”