Talonrage Complete Plugin Kit Update

This forum is for members of the public to post any announcements relating to Diablo 2 Mod Making including mod and patch releases amongst other similar subjects.
Post Reply

0
No votes
 
Total votes: 0

User avatar
talonrage
Retired staff
Arch-Angel
Posts: 1511
Joined: Sat Jul 20, 2002 11:05 pm

Talonrage Complete Plugin Kit Update

Post by talonrage » Tue Feb 07, 2006 8:26 pm

Talonrages Complete Plugin Kit for Patch v1.10

I never got around to actually announcing that this is finished , so I'm doing it now since I just updated it. What this does is combine ALL my currently released plugins into a single install , plus it adds additional content not found in my Plugins.

It is designed to enhance classic Diablo II Expansion , though it can be used as a Starter Kit for a Mod project if the Modder is so inclined to use it.

What this does :

Adds PlugY 4.4

Adds D2Mod System 1.2
Note : There is no need to install these as I've provided the files already with them installed.

Adds over 1300 New Unique Items . There is a total of 3 Different Uniques for every Normal and Exceptional Item as well as Assassin Claws and Amazon Bows/Javelins. There are 2 Different Uniques for each elite item and class-specific item (except those already listed).
All Unique Items have had thier Item Levels reduced to that of thier normal counterparts , so when an item can drop it can be Unique. There is also 460 new Item Graphics for some of the New Uniques.

Added 170 total Runewords. A complete documentation can be found HERE

Adds a total of 100 Different Sets with over 400 Set Pieces . It is heavily themed around senior Phrozen Keep Members.
-Added 11 New Normal Difficulty Item Sets.
-Added 12 New Exceptional Nightmare Difficulty Item Sets.
-Added 12 Uber Hell Difficulty Item Sets.
-Added 28 New Sets made of varies Normal , Exceptional , and Uber items.

Adds a total of 272 New Cubing Formulas. Formulas include improve weapons with all gem types , repairing ethereal items , new crafting formulas , socketing item formulas , and more. Complete crafting formuals can be found HERE

Adds a total of 1007 Prefixes and 700 New Suffixes , either as expanded existing ones , enabling and editing disabled ones , or adding completely new ones. Prefix/Suffix are given a maximum drop level , reducing "crappy" drops in Nightmare and Hell Difficulties.

Adds a mix of Map Plugins as well as my very own custom Maps. A new Dungeon has been added behind Baal's Throne in Worldstone Chamber that spans 50 Levels deep and has 50 Preset Levels , each guarded by its own specific SuperUnique. SuperUnique monsters also have enhanced drop tables , increasing the chance of set/unique items dropped.

Improved Starting Characters.
-All character start with 100 Stat Points
-Receive 6 Stat Points per Level gained
-Reduced mana regenaration rate for all except Necromancer and Sorceress classes.
-Recieve no life , mana , and stamina at level up , but gain greater amounts from increased stats.
-All characters start with a skill on thier weapon.
-All characters start with a Shield , Sash , and the Horadric Cube
-All Characters start with 2 x Rejuvination Potions , 4 x Light Healing Potions , and 2 x Light Mana Potions.

Improves overall Gambling Chances for Uniques to (1%) , Sets to (3%) , and Rares to (16%).

Increased the Maximum stack Values of Arrows , Bolts , Keys , Books of Town Portal , and Books of Identify.

Improved overall Hireling performance by increasing thier Life and Defense and giving them Improved Skills as they level up. The changes can be read about HERE.

Tweaks a number of existing character skills by either improving performance of them or adding Synergy Bonuses. Complete list of changes can be read about Here.

Added 86 new Properties that can be added to Uniques , Sets , Magic items and Rare Items. A complete list can be read about HERE


Download Complete Plugin Kit Here
Last edited by talonrage on Fri Feb 10, 2006 9:30 pm, edited 3 times in total.

User avatar
Darkmage
Retired staff
Paladin
Posts: 129
Joined: Thu May 23, 2002 7:40 am
Location: Janesville, WI, USA

Re: Talonrage Complete Plugin Kit Update

Post by Darkmage » Wed Feb 08, 2006 3:29 am

I like the looks of this. I was looking to just play normal D2 with some spiffy upgrades, just like this. But I don't think I could possibly play D2 without the big inventory/stash/cube deal that's become so standard. Any chance of including one of those as well to make it "complete", at least as far as I'm concerned? :)
End? No the journey doesn't end here. Death is just another path; one that we all must take. The grey rain curtain of this world rolls back, and all turns to silver glass. And then you see it... white shores, and beyond. The far green country, onto a swift sunrise.

User avatar
talonrage
Retired staff
Arch-Angel
Posts: 1511
Joined: Sat Jul 20, 2002 11:05 pm

Re: Talonrage Complete Plugin Kit Update

Post by talonrage » Wed Feb 08, 2006 6:11 am

The plugin has greatly increased Stash and Cube Space , but I've always been a stickler to keeping Inventory normal size as everyone (at least 99% IMO) will just fill up the extra space with charms anyways.

User avatar
TheFallenAngel
Junior Member
Paladin
Posts: 141
Joined: Sun Jul 07, 2002 6:40 pm
Location: The Depths of Hell
Germany

Post by TheFallenAngel » Fri Feb 10, 2006 1:16 pm

excuses for asking this - for which version of diabloII is your 'collection'? *be ashamed*

ok, started with 1.11 and made everything right and always get the "unhandled exception - access violation (c000000005)" error

dunno what to think, dunno what to do
Last edited by TheFallenAngel on Fri Feb 10, 2006 7:34 pm, edited 1 time in total.

... he became a corrupt shadow of his former self -
a fallen angel, trusted neither by heaven nor hell ...

User avatar
Malachai29
Retired staff
Arch-Angel
Posts: 1530
Joined: Sun Jun 15, 2003 7:25 am
Location: Union, Ne
Contact:

Post by Malachai29 » Fri Feb 10, 2006 8:22 pm

If it uses the D2MOD system, it will be for version 1.10

Malachai
RIP Charsi's Forge! :)
Surgeon General's Warning: Double posting may be hazardous to your health

User avatar
TheFallenAngel
Junior Member
Paladin
Posts: 141
Joined: Sun Jul 07, 2002 6:40 pm
Location: The Depths of Hell
Germany

Post by TheFallenAngel » Fri Feb 10, 2006 10:58 pm

after using the plugy 7.01b files and starting the plugy.exe with the -direct -txt parameters it worked - but i'm sure that's not the "correct" way ...

and perhaps not all features will work as intended :roll:
(new items, pre-& suffixes & new and changed areas are working)

... he became a corrupt shadow of his former self -
a fallen angel, trusted neither by heaven nor hell ...

User avatar
Quintine
Posts: 52
Joined: Thu Sep 01, 2005 2:20 am
Location: Wollongong Nsw Australia
Contact:

Re: Talonrage Complete Plugin Kit Update

Post by Quintine » Sat Feb 11, 2006 5:43 am

This looks like a very nice pack.

Congrats, I think it would have made it alot more appealing to noobies by using v7.X of plugy.

User avatar
Arkilae
Posts: 18
Joined: Fri Feb 03, 2006 6:07 pm

Re: Talonrage Complete Plugin Kit Update

Post by Arkilae » Sun Feb 12, 2006 11:49 am

Probably a stupid question but...

Are your unique, and set, magic suffixes prefixes, and the extra maps, plug-ins compatible with 1.11b? Individually I mean, you do quite a bit of work with 1.10, but myself I have modified 1.11b to my own liking, and now that I just accidentally came across your expansive plug-ins would like to use them. :)
Last edited by Arkilae on Sun Feb 12, 2006 11:58 am, edited 1 time in total.

User avatar
talonrage
Retired staff
Arch-Angel
Posts: 1511
Joined: Sat Jul 20, 2002 11:05 pm

Re: Talonrage Complete Plugin Kit Update

Post by talonrage » Sun Feb 12, 2006 12:55 pm

Dunno , I believe Patch 1.11 was a total mistake and will never Mod it. You can try using them , but I have no idea which ones will cause problems and which ones wont (Though I'm positive the expanded levels plugin wont work as its dependent on d2mod system).
Congrats, I think it would have made it alot more appealing to noobies by using v7.X of plugy
At the time the plugin was made , this version of plugy was the most up-to-date , and honestly it seems to work fine as is.
Last edited by talonrage on Sun Feb 12, 2006 12:57 pm, edited 1 time in total.

User avatar
Arkilae
Posts: 18
Joined: Fri Feb 03, 2006 6:07 pm

Re: Talonrage Complete Plugin Kit Update

Post by Arkilae » Sun Feb 12, 2006 1:48 pm

talonrage";p="258373" wrote:Dunno , I believe Patch 1.11 was a total mistake and will never Mod it. You can try using them , but I have no idea which ones will cause problems and which ones wont (Though I'm positive the expanded levels plugin wont work as its dependent on d2mod system).
Congrats, I think it would have made it alot more appealing to noobies by using v7.X of plugy
At the time the plugin was made , this version of plugy was the most up-to-date , and honestly it seems to work fine as is.
First, I mean this with all due respect, and I may come off as an ass.

So, because you believe that because version 1.11 was a mistake, no one using 1.11 will ever get to try your great mods because of your discrimination against it?

User avatar
Malachai29
Retired staff
Arch-Angel
Posts: 1530
Joined: Sun Jun 15, 2003 7:25 am
Location: Union, Ne
Contact:

Post by Malachai29 » Sun Feb 12, 2006 2:02 pm

I feel about 1.11 as Talonrage does, and I know quite a few other modders who also do, but that is neither here nor there. If Talonrage chose to only put his mods out for 1.10, that is his choice, it wouldnt matter if he chose to mod 1.03, it would still be his choice and if we wanted to use his plugins, we would have to drop down to 1.03...or make our own plugins....

Just my $0.02

Malachai
RIP Charsi's Forge! :)
Surgeon General's Warning: Double posting may be hazardous to your health

User avatar
Arkilae
Posts: 18
Joined: Fri Feb 03, 2006 6:07 pm

Post by Arkilae » Sun Feb 12, 2006 2:10 pm

Malachai29";p="258377" wrote:I feel about 1.11 as Talonrage does, and I know quite a few other modders who also do, but that is neither here nor there. If Talonrage chose to only put his mods out for 1.10, that is his choice, it wouldnt matter if he chose to mod 1.03, it would still be his choice and if we wanted to use his plugins, we would have to drop down to 1.03...or make our own plugins....

Just my $0.02

Malachai
What is it about 1.11b that these modders hate so much? What did Blizzard change to cause this?

User avatar
Malachai29
Retired staff
Arch-Angel
Posts: 1530
Joined: Sun Jun 15, 2003 7:25 am
Location: Union, Ne
Contact:

Post by Malachai29 » Sun Feb 12, 2006 2:17 pm

there were more bugs introduced into the coding than features...most code edits have to be rediscovered because they got moved around, hence why d2mod is still for 1.10...the list goes on....
RIP Charsi's Forge! :)
Surgeon General's Warning: Double posting may be hazardous to your health

User avatar
Brother Laz
Forum Legend
Dominion
Posts: 6715
Joined: Mon Jun 03, 2002 10:06 am
Location: Fallen Like Lightning
Contact:

Hand-picked

Re: Talonrage Complete Plugin Kit Update

Post by Brother Laz » Sun Feb 12, 2006 6:15 pm

Arkilae";p="258376" wrote:So, because you believe that because version 1.11 was a mistake, no one using 1.11 will ever get to try your great mods because of your discrimination against it?
I don't agree with this tendency to make 1.10-only mods using 1.10-only features (which IMO excludes a lot of players), but if the modmaker wants to use 1.10-only features like D2mod plugins, it's his choice.

By the way, the Blizzard programmers responsible for 1.11 were fired shortly after the release of the patch. It is said that they were working on D3 as a replacement for the original team (which quit to found Flagship) and it 'didn't meet Blizzard standards' (read: sucked) and therefore the suits booted everyone and shut down North. They're hiring again, but it's certainly a major setback at least.

So, the guys who made 1.11 screwed Diablo 3. If that isn't a good reason to play 1.10, I don't know what is.


The opiate masses who make up the bulk of your players have 1.11, though, and would rather die than upgrade to 1.10. Whether this is a competitive disadvantage for the 1.10 mod (my point of view) or a way to filter out the losers (many others' point of view) is open to debate.
Last edited by Brother Laz on Sun Feb 12, 2006 6:18 pm, edited 1 time in total.
19.may.2007 | Adun Tori Laz.
Median XL released!
Flesyht sa ruobhgien yht etah.


y dont u play the game the way its supposta be played? -SlothNathan

User avatar
onyx
Retired Admin
Throne
Posts: 9377
Joined: Fri Apr 18, 2003 12:38 pm
Location: Sofia, Bulgaria
Contact:

Hand-picked

Re: Talonrage Complete Plugin Kit Update

Post by onyx » Sun Feb 12, 2006 7:44 pm

I wouldn't say that sticking to 1.10 leads to filtering out the losers. I personally have 2 reasons not to use (or even upgrade to) 1.11:

:arrow: No D2Mod in 1.11, and my mod is heavily dependant on it.

:arrow: No expressions in the errors. I'd rather have Expression: ptWarp than Internal error (random number).

Anyway, it's very easy to have both 1.10 and 1.11 (and of course, any other version you want) available on one install of Diablo II, so I really don't see a major problem. And those of the players who can't even follow the simple tutorial of running multiple versions are indeed to be filtered out :mrgreen:
ONYX
Read The Terms of Service before posting!

Back to Hellfire - Site | Forum
Also visit: Incandescence * Diabolic Cartography * Inventharia * Diablo Evolution

User avatar
Quintine
Posts: 52
Joined: Thu Sep 01, 2005 2:20 am
Location: Wollongong Nsw Australia
Contact:

Re: Talonrage Complete Plugin Kit Update

Post by Quintine » Mon Feb 13, 2006 9:36 pm

Dunno , I believe Patch 1.11 was a total mistake and will never Mod it. You can try using them , but I have no idea which ones will cause problems and which ones wont (Though I'm positive the expanded levels plugin wont work as its dependent on d2mod system).
I personaly dont like ver 1.11 at all, however I think that after alot of time many modders may settle down and start modding it.

User avatar
Ulmo
Forum Regular
Angel
Posts: 860
Joined: Fri Jun 04, 2004 5:04 pm

Re: Talonrage Complete Plugin Kit Update

Post by Ulmo » Tue Feb 14, 2006 8:42 am

Arkilae";p="258364" wrote:Are your unique, and set, magic suffixes prefixes, and the extra maps, plug-ins compatible with 1.11b?
General layout of *.txt hasn't changed. Starting with clean *.txt files (Nefarius' sign IIRC), most plug-in should work without problem.

User avatar
Myhrginoc
Retired Admin
Cherub
Posts: 12099
Joined: Sat May 25, 2002 7:28 am
Location: Percussion U
United States of America

Hand-picked

Re: Talonrage Complete Plugin Kit Update

Post by Myhrginoc » Wed Feb 15, 2006 3:17 am

I personaly dont like ver 1.11 at all, however I think that after alot of time many modders may settle down and start modding it.
Part of the reason radical modders don't pay attention to v1.11+ is because these patches haven't settled down. I know why SVR isn't updating D2Mod (which we plugin writers need to do our part) --- first for v1.11 Blizzard changed all the code around in haphazard and unsettling ways. Then v1.11b came around, and scrambled the mess even more. Blizzard Leftover may actually see this as a plus, since we have posted a lot of information about internal workings from the much more accessible versions.
Do the right thing. It will gratify some people and astonish the rest.
~ Mark Twain
Run Diablo II in any version for mods: tutorial
The Terms of Service!! Know them, abide by them, and enjoy the forums at peace.
The Beginner's Guide v1.4: (MS Word | PDF) || Mod Running Scripts || TFW: Awakening

User avatar
megaman1980
Posts: 2
Joined: Sun Feb 19, 2006 2:46 am

Re: Talonrage Complete Plugin Kit Update

Post by megaman1980 » Sun Feb 19, 2006 3:09 am

Hello new to site and I enjoy the mod but having a problem. I have ver. 1.10 on the game but it keeps crashing in certain parts, Isuals dungeon for example, and i'm trying to use zonfires hero editor as well. Any suggestions to correct this would be greatly appeciated.P.S by crashing I mean it either freezes or shuts down immediatly upon entering these places.

User avatar
talonrage
Retired staff
Arch-Angel
Posts: 1511
Joined: Sat Jul 20, 2002 11:05 pm

Re: Talonrage Complete Plugin Kit Update

Post by talonrage » Sun Feb 19, 2006 3:52 am

You need to place all 3 folders (Data , Local , plugY) , all 5 Dll's (d2fgx , d2mod , Plugy , Waypoints , NewTxt) and both InI files (D2Mod , PlugY) into your Root Diablo II Folder.

You then need to select the Desktop Shortcut Icon , right-click it and select properties. Then in the Target Line add -direct -txt
IE:

"C:\Program Files\Diablo II\Diablo II.exe" -direct -txt

If you follow these simply steps , the plugin will work currectly.

User avatar
megaman1980
Posts: 2
Joined: Sun Feb 19, 2006 2:46 am

Re: Talonrage Complete Plugin Kit Update

Post by megaman1980 » Mon Feb 20, 2006 4:08 pm

Thank you Talonrage for your reply but the install and shortcut are not the problem, the game plays great and I followed your instuctions completly. I believe it's a compatability problem with the hero editor that causes the errors when I try to access certain "extra" areas and I was wondering if you have any suggestions on how to use them together.

User avatar
Shadowbane
Posts: 21
Joined: Fri Feb 24, 2006 11:00 am

Post by Shadowbane » Fri Feb 24, 2006 11:04 am

yea, it's happened to me in other mods, namely where items or places were changed. you just gotta go legit :p

Post Reply

Return to “Member Аnnouncements”