PlugY.exe not starting, unknown version.

Discuss applications of D2Mod (v1.10), NefEx (v1.11+), and PlugY, and post suggestions for future plugins.

Moderators: Nefarius, Yohann, SVR

Post Reply
Lamatik
Posts: 5
Joined: Wed May 15, 2013 4:27 pm

PlugY.exe not starting, unknown version.

Post by Lamatik » Wed Apr 04, 2018 2:10 pm

Hey guys!

As the title says it all: I am unable to start the PlugY.exe, it says "PlugY isn't compatible with this version: UNKNOW"
Tried with the ZIP files, with the installer; same thing. There shouldn't be anything wrong with the game version as I am using Eastern Sun on it and it is all fine and the PlugY that comes with it.
I just wanted to mess with the 1.10 Vanilla.
I also saw that there is a log in there, here is the output:

* PlugY is called from D2gfx.dll

***** Load D2 Libraries *****
SmackW32.dll loaded successfully at: 03310000
D2Common.dll loaded successfully at: 03B20000
ijl11.dll loaded successfully at: 60000000
D2Gdi.dll loaded successfully at: 6F830000
D2Win.dll loaded successfully at: 6F8A0000
D2sound.dll loaded successfully at: 6F980000
D2Launch.dll loaded successfully at: 6FA10000
D2gfx.dll loaded successfully at: 6FA70000
D2Game.dll loaded successfully at: 6FC30000
D2Client.dll loaded successfully at: 6FAA0000
D2Net.dll loaded successfully at: 6FC00000
D2Lang.dll loaded successfully at: 6FC10000
D2CMP.dll loaded successfully at: 6FDF0000
Bnclient.dll loaded successfully at: 6FF00000
Fog.dll loaded successfully at: 6FF50000
Storm.dll loaded successfully at: 6FFB0000


***** Get dll versions *****
version of D2Common.dll 1.10
version of D2Gdi.dll 1.10
version of D2Win.dll 1.10
version of D2Launch.dll 1.10
version of D2gfx.dll 1.10
version of D2Client.dll 1.10
version of D2Net.dll 1.10
version of D2Lang.dll 1.10
version of D2Game.dll 1.10
version of Fog.dll 1.10
version of Storm.dll 1.10


Bad index fct 10326 for 03B20000
Bad index fct 10329 for 03B20000
Bad index fct 11007 for 03B20000
Bad index fct 10581 for 03B20000
Bad index fct 10598 for 03B20000
Bad index fct 10673 for 03B20000
***** PARAMETERS *****

Can't open parameters files: Default values used.



***** ENDING DIABLO II *****

This D2Common.dll seems to be the problem. Anyone have a clue as to why ?
Vanilla and ES run flawlessly.

Post Reply

Return to “PlugY|NefEx|D2Mod”