Help Requested! - Installing D2Ex2

Post anything else D2 related here but remember this ISN'T a hack site. All posts directly related to battle.net hacking will be deleted.
Post Reply
User avatar
AugusDogus
Posts: 1
Joined: Sun Jun 03, 2018 12:43 pm
Location: Edgeville
Contact:
United States of America

Help Requested! - Installing D2Ex2

Post by AugusDogus » Sun Jun 03, 2018 1:03 pm

Hello!

I recently rediscovered Diablo II and as such my friends and I have been playing on a virtual lan together for the past few days. As we're mostly casual gamers we are used to newer games having higher resolution settings. I came across a mod by @lolet called D2Ex2, but I am having some serious issues finding any up-to-date information on how to get this thing installed and running.

I am on 1.13d as the github readme states this requires (or 1.11b) and I've got as far as downloading the D2Ex2_113d.dll from the releases tab and adding it to the root directory of my Diablo II folder, but past that I am lost. I have also been trying to compile the project from source to see if that yields any better results, but I am running into issues on that front as well.

If someone could give me some much needed guidance I would be very appreciative! Or if you could direct me in the right direction of achieving the same result of a higher resolution that this mod offers, that would also be great.

Thanks!

User avatar
kingpin
Site Admin
Cherub
Posts: 10864
Joined: Sat Jan 11, 2003 12:51 pm
Contact:
Sweden

Hand-picked

Re: Help Requested! - Installing D2Ex2

Post by kingpin » Tue Jun 05, 2018 1:30 pm

The dll need be read by game. Either use plugy or d2se Both supports to add custom dll

User avatar
Truedat775
Posts: 21
Joined: Fri Mar 02, 2018 9:14 am
Contact:
United States of America

Re: Help Requested! - Installing D2Ex2

Post by Truedat775 » Tue Jun 05, 2018 3:07 pm

I am also having problems with D2Ex2. I keep getting a "disk read error" warning when Diablo II starts up. I've tried installing every C++ Redistributable package up until 2015 and I tried installing almost every .net framework up until 4.7 and it still won't work.

User avatar
thaison
Dark Alliance Beta Test
Crusader
Posts: 58
Joined: Fri Apr 03, 2015 11:59 am
Location: Viet Nam
Vietnam

Re: Help Requested! - Installing D2Ex2

Post by thaison » Thu Jun 07, 2018 5:48 am

You should create your own project, the source code on github is the basis for you.

User avatar
Talic
Posts: 43
Joined: Sat Mar 10, 2018 9:09 am
Croatia

Re: Help Requested! - Installing D2Ex2

Post by Talic » Fri Jun 08, 2018 1:53 pm

I can run the basic file fine through D2SE, but I can't compile the rest, I get this error:

Code: Select all

1>------ Build started: Project: D2Ex2, Configuration: Debug 1.13d Win32 ------
1>Updating build number...
1>'sed' is not recognized as an internal or external command,
1>operable program or batch file.
1>'grep' is not recognized as an internal or external command,
1>operable program or batch file.
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(123,5): error MSB3073: The command "sed -i -r 's/^(.*) ([0-9]*)$/echo "\1" \$((\2+1))/ge' C:\Users\Tex\Desktop\D2Ex2-master\Build.h
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(123,5): error MSB3073: tasklist | grep -q Game.exe && taskkill /f /im Game.exe
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(123,5): error MSB3073: EXIT 0
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.CppCommon.targets(123,5): error MSB3073: :VCEnd" exited with code 255.
1>Done building project "D2Ex2.vcxproj" -- FAILED.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
So I guess those sed and grep are the problem :mrgreen:

There is also some build.h which doesn't exist, someone said "you can use build.h from another release or that you can create a radnom one"....but how :scratchhead: :scratchhead:

It would be great if someone who use visual studio could check into this.

It seems that mod has some nice options, but also I'm sure there is a lot more after you build the files, if you are able to of course:
Image
Image
Image
Thank You for all Your hard work. :leftthumb:

User avatar
Truedat775
Posts: 21
Joined: Fri Mar 02, 2018 9:14 am
Contact:
United States of America

Re: Help Requested! - Installing D2Ex2

Post by Truedat775 » Fri Jun 15, 2018 8:39 pm

Try changing the build settings to 'Release 1.13d' instead of Debug. I can build it fine on VS2013, but I keep getting multiple errors when the game loads and if I build it with multires, D2 won't even load at all.

Post Reply

Return to “Diablo 2 Chatter”