Need help with PlugY error with 1.10

Discuss applications of D2Mod (v1.10), NefEx (v1.11+), and PlugY, and post suggestions for future plugins.

Moderators: Nefarius, Yohann, SVR

Post Reply
User avatar
prawn
Junior Member
Paladin
Posts: 106
Joined: Sat Oct 27, 2012 12:21 am
Great Britain

Need help with PlugY error with 1.10

Post by prawn » Sun Jan 13, 2019 10:09 pm

Hi everyone, I was planning to come back to modding but I have a weird error that I just don't understand!?

I have just freshly installed d2 from cds and then tried to run my old 1.10 mod with d2se. I got an error saying plugy wouldnt work - I thought my mistake was because i updated to 1.14 before i put on d2se so uninstalled it all and reinstalled again.

So now i have just basic d2 install with basic d2se - no mods just the cores. Plugy works for all available versions apart from 1.10? I don't understand why that could be possible?

Below is the plugy log file - can anyone help? I would really appreciate it.

<----------------------------------------------->

A Plugin by Yohann
version 10.00


<---------- Starting Diablo II Plugin ---------->


* PlugY is called from D2mod.dll

***** Load D2 Libraries *****
SmackW32.dll loaded successfully at: 08090000
D2Common.dll loaded successfully at: 07170000
ijl11.dll loaded successfully at: 60000000
D2Gdi.dll loaded successfully at: 6F830000
D2Win.dll loaded successfully at: 07620000
D2sound.dll loaded successfully at: 6F980000
D2Launch.dll loaded successfully at: 07FE0000
D2gfx.dll loaded successfully at: 06FD0000
D2Game.dll loaded successfully at: 07310000
D2Client.dll loaded successfully at: 08180000
D2Net.dll loaded successfully at: 06ED0000
D2Lang.dll loaded successfully at: 06F60000
D2CMP.dll loaded successfully at: 07060000
Bnclient.dll loaded successfully at: 07F90000
Fog.dll loaded successfully at: 06F00000
Storm.dll loaded successfully at: 06E80000


***** Get dll versions *****
version of D2Common.dll 1.10
version of D2Gdi.dll 1.10
version of D2Win.dll unknow, try with 1.13
version of D2Launch.dll unknow, try with 1.13
version of D2gfx.dll 1.10
version of D2Client.dll 1.10
version of D2Net.dll 1.10
version of D2Lang.dll 1.10
version of D2Game.dll 1.10
version of D2CMP.dll 1.10
version of Fog.dll 1.10
version of Storm.dll 1.10


Bad index fct 11163 for 07170000
***** PARAMETERS *****
Parameters file is opened.

Reading parameters.

USER: active_plugin = 1
DLL: active_DisableBattleNet = 0
USER: active_logFile = 0
USER: active_Commands = 0
USER: active_CheckMemory = 0
DLL: active_othersFeatures = 0
USER: dllFilenames = |

USER: active_ChangeLanguage = 0
DLL: active_LanguageManagement = 0

USER: active_changingSavePath = 0

USER: active_VersionTextChange = 1
USER: versionText =
USER: modVersionColor = 0
USER: active_PrintPlugYVersion = 1
USER: colorOfPlugYVersion = 4

USER: active_bigStash = 1
USER: active_multiPageStash = 1
USER: maxSelfPages = 4294967295
USER: nbPagesPerIndex = 10
USER: nbPagesPerIndex2 = 100
USER: active_sharedStash = 1
DLL: DLL: DLL: DLL: DLL: DLL: DLL: DLL: DLL: DLL: DLL: DLL: DLL: DLL: Buttons Positions: -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
USER: maxSharedPages = 4294967295
DLL: sharedStashFilename = SharedStashSave
USER: separateHardSoftStash = 1
USER: displaySharedSetItemNameInGreen = 1
USER: active_sharedGold = 1

USER: active_StatsPoints = 1
USER: keyUsedForUnassignStatPoint = 18 (0x19f970)
USER: active_StatsShiftClickLimit = 0

USER: active_StatPerLevelUpChange = 0

USER: active_SkillsPoints = 1
DLL: unassignSkillsPointsOneByOne = 0
DLL: posXUnassignSkillBtn = -1
DLL: posXUnassignSkillBtn = -1

USER: active_SkillPerLevelUpChange= 0

USER: active_WorldEvent = 1
USER: showSOJSoldCounterInAllDiff = 0
USER: itemsToSell = The Stone of Jordan
USER: worldEventmonsterID = 333
USER: valueOfOwnSOJSold = 100
USER: valueInitSOJSoldMin = 200
USER: valueInitSOJSoldDelta = 2801
USER: triggerAtSolJSoldMin = 75
USER: triggerAtSolJSoldDelta = 51
USER: active_AutomaticSell = 1
USER: timeBeforeAutoSellMin = 0
USER: timeBeforeAutoSellDelta = 1200001

USER: active_UberQuest = 0 (Warning : this feature is only for LoD version 1.11 or higher, so it's automatically disabled)

USER: active_newInterfaces = 1
USER: selectMainPageOnOpenning = 1
DLL: printBackgroundOnMainPage = 1

USER: active_alwaysRegenMapInSP = 0
USER: nbPlayersCommandByDefault = 0
USER: active_DisplayItemLevel = 1
USER: active_AlwaysDisplayLifeMana= 0
USER: active_RunLODs = 0
USER: active_EnabledTXTFilesWithMSExcel= 0

USER: active_DisplayBaseStatsValue= 1

USER: active_LadderRunewords = 1

USER: active_EnabledCowPortalWhenCowKingWasKill= 1

Reading parameters end.


***** Custom libraries *****
No custom libraries to load.


***** Unprotect Libraries *****
D2Common.dll successfully hooked. (07171000,0008D000)
D2Client.dll successfully hooked. (08181000,000CC000)
D2Lang.dll successfully hooked. (06F61000,0000A000)
D2Game.dll successfully hooked. (07311000,000F6000)
Fog.dll successfully hooked. (06F01000,00020000)
Storm.dll successfully hooked. (06E81000,00030000)
D2Launch.dll successfully hooked. (07FE1000,00020000)
D2gfx.dll successfully hooked. (06FD1000,0000B000)


***** INSTALL FUNCTIONS *****
Patch D2Launch for set not on realm variable. (VariableonRealm)
Error : BYTE 81 wanted but 01 found to change memory at 07FF9295

BYTE 07FF9295 : 81->E8
Error : DWORD 000400EC wanted but EB000000 found to change memory at 07FF9296

DWORD 07FF9296 : 000400EC->0053F126
Error : BYTE 00 wanted but 29 found to change memory at 07FF929A

BYTE 07FF929A : 00->90
Error : BYTE BE wanted but 94 found to change memory at 07FF7B8E

BYTE 07FF7B8E : BE->E8
Error : DWORD 00000040 wanted but 83000009 found to change memory at 07FF7B8F

DWORD 07FF7B8F : 00000040->0054085D
Error : BYTE BA wanted but CE found to change memory at 07FF1F36

BYTE 07FF1F36 : BA->E8
Error : DWORD 00000400 wanted but 00631AE8 found to change memory at 07FF1F37

DWORD 07FF1F37 : 00000400->005464F5

Patch D2Game for fixing ptClient removing bug. (VariableonRealm)
BYTE 07312B97 : 39->E8
DWORD 07312B98 : 8B0C7429->012258B4
BYTE 07312B9C : C1->90

Patch D2Launch to print PlugY version. (PrintPlugYVersion)
Error : Read access missing to patch memory at 07FF8061.
Please install a clean version of Lord of Destruction

You can avoid this error message by setting ActiveCkeckMemory=0 in PlugY.ini
(WARNING: Be careful when you use it, it shouldn't be used by common user)

User avatar
prawn
Junior Member
Paladin
Posts: 106
Joined: Sat Oct 27, 2012 12:21 am
Great Britain

Re: Need help with PlugY error with 1.10

Post by prawn » Mon Jan 14, 2019 10:34 pm

I am still not sure how or why this happened but I replaced the plugy.dll in the 1.10f core folder of d2se with a plugy.dll file from reign of shadow mod and it works ....?

Post Reply

Return to “PlugY|NefEx|D2Mod”